Red and Black

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

 

#include<iostream>
using namespace std;
char  tile[21][21];
bool  bj[21][21] = { 0 };                        //标记是否访问过
int   dir[4][2] = { -1,0,0,-1,0,1,1,0 };
int w, h;
void dfs(int, int);
int main()
{
	while (cin >> w >> h)
	{
		if (w == 0 && h == 0) { break; }
		int i, j, sum = 0;
		for (i = 0; i < h; i++)                    //输入地图
		{
			for (j = 0; j < w; j++)
			{
				cin >> tile[i][j];
			}
		}
		for (i = 0; i < h; i++)
		{
			for (j = 0; j < w; j++)
			{
				if (tile[i][j] == '@')            //寻找起点
				{
					dfs(i, j);                   //进行深搜
				}
			}
		}
		for (i = 0; i < h; i++)
		{
			for (j = 0; j < w; j++)
			{
				if (bj[i][j] == 1)
				{
					sum += 1;
				}
			}
		}
		cout << sum << endl;
	}
}

void dfs(int x, int y)
{
	bj[x][y] = 1; int x1, y1, i;
	for (i = 0; i < 4; i++)
	{
		x1 = x + dir[i][0];
		y1 = y + dir[i][1];
		if ((bj[x1][y1] == 0) && (tile[x1][y1] == '.') && (x1 >= 0) && (x1 < h) && (y1 >= 0) && (y1 < w))                                  //条件判断
		{
			dfs(x1, y1);                             //继续深搜
		}
	}
}

此代码有错误,每次运行后应将标记还原。

for (i = 0; i < h; i++)
		{
			for (j = 0; j < w; j++)
			{
				bj[i][j] = 0;
			}
                }

即可。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值