POJ3061 Subsequence(尺取)

2 篇文章 0 订阅

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

Solution

不看小白鼠我也不会做,然后发现理解了就很简单了
单开一个数组求和,二分找差值>=s的下标(注意控制范围&&注意判0)

AC代码

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#define inf 0x3f3f3f3f
using namespace std;
int main()
{
    int t;
    scanf("%d",&t);
    int a[100005];
    int sum[100005];
    for(int k=1;k<=t;++k)
    {
        int n,s;
        int ans=inf;
        scanf("%d %d",&n,&s);
        for(int i=1;i<=n;++i)
        {
            scanf("%d",&a[i]);
        }
        sum[1]=a[1];
        for(int i=2;i<=n;++i)
        {
            sum[i]=sum[i-1]+a[i];
        }
        if(sum[n]<s)
        {
            printf("0\n");
            continue;
        }
        else
        {
            for(int i=1;sum[i]+s<=sum[n];++i)
            {
                int mid=lower_bound(sum+1+i,sum+1+n,sum[i]+s)-sum;
                ans=min(mid-i,ans);
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值