Constructing Roads(HDU 1102)最小生成树&并查集&优先队列

HDU1102 Constructing Roads

题目链接

Problem Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input:

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output:

179

题目大意

输入一个N*N矩阵,第 i 行第 j 个数代表节点 i 到节点 j 之间的距离。问最少修多长的路可以把所有节点连接起来。

解题思路

先用一个优先队列保存每两个点及它们之间距离的信息,输入的二维矩阵只需要记录上半个三角形或者下半个三角形的数据。然后输入已经连接好的边,过程中通过并查集数组完成边的连接。然后遍历队列,每次队首出来的都是距离最短的两个点,检查两个点是否有同一个根节点,若没有,在两点之间建立一条边,累加到最终的答案里。当所有节点都连到同一个根节点时,得出结果。

AC代码

#include <bits/stdc++.h>
using namespace std;
const int N = 1005;

struct Magic{
    int u;
    int v;
    int w;
    friend bool operator<(const Magic&a,const Magic&b){
		return a.w>b.w;
	}
};

int bin[N];
int findx(int x)
{
	if(x==bin[x]){
        return x;
    }
    bin[x]=findx(bin[x]);
    return bin[x];
}

int main(int argc, char **argv)
{
	int n;
    //freopen("./input.txt","r",stdin);
    while(~scanf("%d",&n)){
        int weight,T;
        for(int i=0; i<N; i++){
            bin[i]=i;
        }
        priority_queue<Magic> q;
        Magic x;
        for(int i=1; i<=n; i++){
            for(int j=1; j<=n; j++){
                scanf("%d",&weight);
                if(i<=j){continue;}
                x.u=i;
                x.v=j;
                x.w=weight;
                q.push(x);
            }
        }
        scanf("%d",&T);
        int a,b;
        while(T--){
            scanf("%d%d",&a,&b);
            bin[findx(b)]=findx(a);
        }
        long long ans=0;
        while(!q.empty()){
            x=q.top();
            q.pop();
            int fx=findx(x.u);
            int fy=findx(x.v);
            if(fx!=fy){
                bin[fy]=fx;
                ans+=x.w;
            }
        }
        printf("%lld\n",ans);
    }
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

征服所有不服

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值