【剑指紫金港】1007 Maximum Subsequence Sum 动态规划&滑动窗口

A 1007 Maximum Subsequence Sum

题目链接

Problem Description

Given a sequence of K integers { N​1 , N2​​ , …, N​K }. A continuous subsequence is defined to be { N​i , N​i+1 , …, N​j } where 1 ≤ i ≤ j ≤ K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

题目大意

给k个数字,求最大子序列和。如果最大子序列和为负,则令最大子序列和为0,输出序列的第一个和最后一个数。

解题思路

既然是动态规划,那么只要考虑两个状态,dp[i-1](前i-1个数的最大子序列和)和dp[i](前i个数的最大子序列和)。先对dp[i-1]分析,如果前i-1个数的最大子序列和小于0,那一定是对增加子序列和没有帮助的,要舍弃,更新临时左端点"l"为i。然后对dp[i]分析,只有两种可能一种就是第i个数(当dp[i-1]不给力是负数时),另一种是dp[i-1] + dp[i]。然后更新maxSum。

AC代码

#include <bits/stdc++.h>
using namespace std;
#define max(a, b) ((a) > (b) ? (a) : (b))
const int maxn = 10005;
int dp[maxn],num[maxn];
int main(int argc, char **argv){
    int k;
    scanf("%d",&k);
    for(int i=0; i<k; i++){
        scanf("%d",&dp[i]);
        num[i]=dp[i];  //用于输出结果,存储对应下标的数
    }
    int l=0, left=0, right=k-1, maxSum=dp[0];
    for(int i=1; i<k; ++i){
    	if(dp[i-1] < 0) l = i;
        dp[i] = max(dp[i], dp[i-1]+dp[i]);
        if(dp[i] > maxSum){
            maxSum = dp[i];
            right = i;
            left = l;
        }
    }
    maxSum=max(maxSum, 0);
    printf("%d %d %d",maxSum,num[left],num[right]);
    return 0;
}  
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

征服所有不服

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值