01-复杂度2 Maximum Subsequence Sum (25分)

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

//改进在线处理算法,带有位置标记
#include<bits/stdc++.h>
using namespace std;

void maxSubSeqSum(vector<int>& arr){
    int first=0,last=0;
    //res和res2都设置为-1是因为本函数不处理全是负数的情形
    //在更新标记位置,当第一次res2=0的时候需要进行更新res及first和last
    int res=-1; 
    int first2=0,last2=0;
    int res2=-1;
    int tmp=0;
    for(int i=0;i<arr.size();i++){
        tmp+=arr[i];
        last2=i;
        if(tmp>res2){ 
            res2=tmp;
        }

        if(res2>res){ //更新标记
            res=res2;
            first=first2;
            last=last2;            
        }

        if(tmp<0){
            tmp=0;
            if(i+1<arr.size()){
                first2=i+1;  //下一次尝试first2的位置
            }
        }
    }
    cout<<res<<" "<<arr[first]<<" "<<arr[last]<<endl;
}

int main(){
    int k;
    cin>>k;
    vector<int> arr(k,0);
    bool isAllNegative=true; //假定全部都是负数
    for(int i=0;i<k;i++){
        cin>>arr[i];
        if(arr[i]>=0){
            isAllNegative=false; //只要有一个不是负数,标志清除
        }
    }
    if(isAllNegative){ //全是负数直接处理
        cout<<0<<" "<<arr[0]<<" "<<arr[arr.size()-1]<<endl;
    }else{ //反之,丢给maxSubSeqSum函数进行处理
        maxSubSeqSum(arr);
    }
    
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值