Bone Collector(HDU 2602)01背包模板

Bone Collector

题目链接

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
hdu2602

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input:

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output:

14

题目大意

有n个物品,一个容量为v的背包。先输入n个物品的价值,再输入n个物品的体积。问这个背包最多能装多少价值的物品?

解题思路

01背包模板题,具体看代码好好理解。初始化方面如果题目问的是“恰好装满背包”时的最优解,那么f [0] 为0,其他 f [1…V]设置为负无穷。如果没有要求把背包全部装满,则和本题一样将 f [0…V]全部设置为0。

AC代码

#include <bits/stdc++.h>
using namespace std;
#define max(a, b) ((a) > (b) ? (a) : (b))
#define INF 0x3f3f3f3f
const int NINF = -(unsigned(-1)>>1)-1;
typedef long long ll;

const int maxn = 1005;

int f[maxn],c[maxn],w[maxn];

int main(int argc, char **argv){
    int t,n,v;
    while(~scanf("%d",&t)){
        while(t--){
            fill(f, f+maxn, 0);
            scanf("%d%d",&n,&v);
            for(int i=1; i<=n; i++){
                scanf("%d",&w[i]);
            }
            for(int i=1; i<=n; i++){
                scanf("%d",&c[i]);
            }
            for(int i=1; i<=n; i++){
                for(int j=v; j>=c[i]; j--){
                    f[j] = max(f[j], f[j-c[i]]+w[i]);
                }
            }
            printf("%d\n",f[v]);
        }
    }
    return 0;
}  
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

征服所有不服

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值