【剑指紫金港】1018 Public Bike Management Dijkstra+DFS

12 篇文章 0 订阅
4 篇文章 0 订阅

A 1018 Public Bike Management

题目链接

Problem Description

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.
pbmc
The above figure illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S​3​​ , we have 2 different shortest paths:

  1. PBMC -> S​1​​ -> S3. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S​1​​ and then take 5 bikes to S​3​​ , so that both stations will be in perfect conditions.

  2. PBMC -> S​2 -> S​3​​ . This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input

Each input file contains one test case. For each case, the first line contains 4 numbers: C​max (≤100), always an even number, is the maximum capacity of each station; N (≤500), the total number of stations; S​p, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers C​i​​ (i=1,⋯,N) where each C​i​​ is the current number of bikes at S​i​​ respectively. Then M lines follow, each contains 3 numbers: S​i​​ , S​j​​ , and T​ij​​ which describe the time T​ij​​ taken to move betwen stations S​i​​ and S​j​​ . All the numbers in a line are separated by a space.

Output

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0−>S​1​​ −>⋯−>S​p​​ . Finally after another space, output the number of bikes that we must take back to PBMC after the condition of S​p​​ is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge’s data guarantee that such a path is unique.

Sample Input:

10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1

Sample Output:

3 0->2->3 0

题目大意

有N个点(1…N),M条边,编号为0的点是起点。输入N个点和M条边的权值,给出一个Cmax和终点Sp。求起点到终点的最短路径并输出,同时在走这条路线时:从起点带出x辆单车,每到一个节点时,如果该节点的值小于Cmax/2,则从x中拿出若干台单车补充该节点权值到Cmax/2,反之则从该节点取出一部分单车加到x中去,最终要满足整条路径所有节点权值都为Cmax/2。求在最短路径下初始的x值和经过终点后的x值,如果有多条最短路,选择初始x值最小的方案输出,如果还无法确定,选择经过终点后x值最小的方案输出。

解题思路

多条最短路选最优方案题型,可以结合A 1087题感悟理解,这题裸DFS不会超时,但是作为一类题型,要掌握效率最好的一种方法。Dijkstra算法部分一模一样,先确定所有最短路方案,然后在最短路方案中搜索。这题有一个小细节,就是Dijkstra的起点要选终点而不是起点,因为如果从起点开始,回溯路径时是从终点往起点回溯,而这道题涉及初始x值的求解,从后往前和从前往后的结果完全不一样,所以Dijkstra从终点Sp开始,dfs从起点0开始。now代表着假如一开始带出0台单车,此时手上有多少台单车,是每个节点权值相对Cmax的差值的累加,take保存初始x值的相反数。

AC代码

#include<bits/stdc++.h>
using namespace std;
#define INF 0x3f3f3f3f
const int maxn = 505;
int w[maxn],d[maxn],vis[maxn],Cmax,Sp,n,m,u,v,wei,send=INF,bac=INF;
vector<pair<int,int> > G[maxn];
vector<int>path[maxn];
vector<int>ans,npath;
void dij(int s){
	fill(d,d+maxn,INF);
	fill(vis,vis+maxn,0);
	d[s]=0;
	for(int i=0;i<=n;i++){
		int p=-1,minl=INF;
		for(int j=0;j<=n;j++){
			if(!vis[j] && d[j]<minl){
				minl=d[j];
				p=j;
			}
		}
		if(p==-1) break;
		vis[p]=1;
		for(int j=0,len=G[p].size();j<len;j++){
			int to=G[p][j].first,dis=G[p][j].second;
			if(!vis[to] && minl+dis<d[to]){
				d[to]=minl+dis;
				path[to].clear();
				path[to].emplace_back(p);	
			}else if(!vis[to] && minl+dis==d[to]){
				path[to].emplace_back(p);
			}
		}
	}
}
void dfs(int x,int take,int now){
	if(x!=0){
		now+=w[x]-Cmax;
		take=min(take,now);
	}
	if(x==Sp){
		if(abs(take)<send){
			send=abs(take);
			ans=npath;
			bac=now+abs(take);
		}else if(abs(take)==send){
			if(now+send<bac){
				bac=now+send;
				ans=npath;
			}
		}
		return ;
	}
	for(int i=0,len=path[x].size();i<len;i++){
		npath.emplace_back(path[x][i]);
		dfs(path[x][i],take,now);
		npath.pop_back();
	}
	return ;
}
int main(){
	scanf("%d%d%d%d",&Cmax,&n,&Sp,&m);
	Cmax/=2;
	for(int i=1;i<=n;i++) scanf("%d",&w[i]);
	for(int i=0;i<m;i++){
		scanf("%d%d%d",&u,&v,&wei);
		G[u].emplace_back(v,wei);
		G[v].emplace_back(u,wei);
	}
	dij(Sp);
	dfs(0,0,0);
	printf("%d 0",send);
	for(int i=0;i<ans.size();i++){
		printf("->%d",ans[i]);
	}
	printf(" %d",bac);
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

征服所有不服

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值