【剑指紫金港】1043 Is It a Binary Search Tree 二叉搜索树

17 篇文章 0 订阅
12 篇文章 0 订阅

A 1043 Is It a Binary Search Tree

题目链接

Problem Description

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output

For each test case, first print in a line YESif the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NOif not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

题目大意

给出一个先序序列,问这个是不是一个二叉搜索树或者一个二叉镜像搜索树的先序序列,如果是,输出它的后序序列。

解题思路

根节点是先序序列的第一个,它的左子树全部小于(大于等于)根节点,它的右子树全部大于等于(小于)根节点,不断二分一个先序序列为根节点、左子树、右子树,然后存储后序序列。用bst标记当前是什么类型的搜索树(1是二叉搜索树,3是二叉镜像搜索树),一旦发现当前先序序列不满足bst对应类型的要求,将bst修改为3,返回。

AC代码

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1005;

int pre[maxn],n,bst=0;
vector<int> pos;

void dfs(int preL,int preR){
    if(preL>preR){
        return ;
    }
    int root=pre[preL],i=preL+1,j=preR;
    if(bst==0){
        if(pre[i]<root){
            bst=1;
        }else{
            bst=2;
        }
    }
    if(bst==1){ //是BST
        while(i<=preR && pre[i]<root){
            i++;
        }
        while(j>preL && pre[j]>=root){
            j--;
        }
    }else if(bst==2){ //是镜像BST
        while(i<=preR && pre[i]>=root){
            i++;
        }
        while(j>preL && pre[j]<root){
            j--;
        }
    }else{
        return;
    }
    if(i-j!=1){
        bst=3;
        return;
    }
    dfs(preL+1,i-1);
    dfs(j+1,preR);
    pos.emplace_back(root);
}

int main(){
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        scanf("%d",&pre[i]);
    }
    dfs(0,n-1);
    if(bst==3){
        printf("NO");
    }else{
        printf("YES\n");
        for(int i=0;i<n;i++){
            if(i>0){
                printf(" ");
            }
            printf("%d",pos[i]);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

征服所有不服

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值