【剑指紫金港】1117 Eddington Number 大年初一第一篇!

A 1117 Eddington Number

题目链接

Problem Description

British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an “Eddington number”, E – that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington’s own E was 87.

Now given everyday’s distances that one rides for N days, you are supposed to find the corresponding E (≤N).

Input

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​ ), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

Output

For each case, print in a line the Eddington number for these N days.

Sample Input:

10
6 7 6 9 3 10 8 2 7 8

Sample Output:

6

题目大意

给出n个数,其中大于x的数刚好有x个,求出这个最大的x。

解题思路

x最大的可能是n,从大往小找。先将n个数从小到大排序,然后从下标为0的数(i=0)开始,对于0~miles[i]之间的所有可能的x,大于x的共有n-i个,找到第一个等于n-ix就是答案。

AC代码

#include<bits/stdc++.h>
using namespace std;

int main(){
    int n,ans=0,flag=0;
    scanf("%d",&n);
    vector<int> miles(n);
    for(int i=0;i<n;i++) scanf("%d",&miles[i]);
    sort(miles.begin(),miles.end());
    for(int i=0;i<n;i++){
        int num=n-i;
        for(int j=0;j<miles[i];j++){
            if(num==j){
                ans=num;
                flag=1;
                break;
            }
        }
        if(flag) break;
    }
    printf("%d",ans);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

征服所有不服

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值