【剑指紫金港】1143 Lowest Common Ancestor

A 1143 Lowest Common Ancestor

题目链接

Problem Description

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
Given any two nodes in a BST, you are supposed to find their LCA.

Input

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and Ais the key. But if Ais one of U and V, print X is an ancestor of Y. where Xis Aand Yis the other node. If U or V is not found in the BST, print in a line ERROR: U is not found.or ERROR: V is not found.or ERROR: U and V are not found..

Sample Input:

6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

题目大意

给出一个BST(二叉搜索树)的先序序列,求任意两点的最早公共祖先。

解题思路

LCA类题目,都是 不需要建树的!!! 核心就是通过给出的输入,找到第一个能将任意两点分为左右两边的节点ans。因为是BST的先序序列,所以ans在数组中必然先于u和v出现,故找到第一个满足 (u<pre[i] && pre[i]<v) || (v<pre[i] && pre[i]<u) || (pre[i]==u) || (pre[i]==v) 的i点即可。

AC代码

#include <bits/stdc++.h>
using namespace std;
unordered_map<int,bool>num;
int main() {
    int m,n,u,v,ans;
    scanf("%d%d",&m,&n);
    vector<int> pre(n);
    for(int i=0;i<n;i++){
        scanf("%d",&pre[i]);
        num[pre[i]]=true;
    }
    for(int cnt=0;cnt<m;cnt++){
        scanf("%d%d",&u,&v);
        if(num[u]==false && num[v]==false){
            printf("ERROR: %d and %d are not found.\n",u,v);
        }else if(num[u]==false){
            printf("ERROR: %d is not found.\n",u);
        }else if(num[v]==false){
            printf("ERROR: %d is not found.\n",v);
        }else{
            for(int i=0;i<n;i++){
                if((u<pre[i] && pre[i]<v) || (v<pre[i] && pre[i]<u) || (pre[i]==u) || (pre[i]==v)){
                    ans=pre[i];
                    break;
                }
            }
            if(ans==u){
                printf("%d is an ancestor of %d.\n",u,v);
            }else if(ans==v){
                printf("%d is an ancestor of %d.\n",v,u);
            }else{
                printf("LCA of %d and %d is %d.\n",u,v,ans);
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

征服所有不服

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值