铁轨 c语言算法

There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.
The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has N ≤ 1000 coaches numbered in increasing order 1,2,...,N. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be a1.a2,...,aN. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station. Input The input file consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of 1,2,...,N. The last line of the block contains just ‘0’. The last block consists of just one line containing ‘0’. Output The output file contains the lines corresponding to the lines with permutations in the input file. A line of the output file contains ‘Yes’ if it is possible to marshal the coaches in the order required on the correspondinglineoftheinputfile. Otherwiseitcontains‘No’. Inaddition, thereisoneemptylineafter the lines corresponding to one block of the input file. There is no line in the output file corresponding to the last “null” block of the input file.

翻译:

在PopPush市有一个著名的火车站。那里的乡村丘陵多得令人难以置信。这个车站是上个世纪建造的。不幸的是,当时的资金极为有限。只建立一条地面轨道是可能的。此外,事实证明,空间站可能只是一个死胡同(见图),由于缺乏可用空间,它只能有一条轨道。当地的传统是,每一列从A方向来的火车都在B方向继续前进,车厢也以某种方式进行了重组。假设方向的火车到达一个有N≤1000教练在增加订单编号1,2,…,N。列车重组负责人必须知道是否有可能对继续沿B方向行驶的列车进行编组,使其订单为a1.a2,…,aN。帮助他并编写一个程序来决定是否有可能获得所需的教练顺序。你可以假设单教练可以断开火车之前进入车站,他们可以移动,直到他们在跑道上的方向b .你也可以假设在任何时候可以有必要尽可能多的教练在车站。但是,一旦一辆长途汽车进入车站,它就不能回到a方向的轨道上,一旦它离开车站,它也不能回到B方向的车站上。输入文件由行块组成。除了最后一个块之外,每个块都描述了一列火车和可能更多的重组需求。块的第一行是上面描述的整数N。块的下一行每一行都有一个1、2、…、N的排列。块的最后一行只包含“0”。最后一个块只包含一行“0”。输出文件包含与输入文件中排列的行对应的行。输出文件的一行包含“Yes”,如果可以按照theinputfile对应的linedingrequired的顺序对coach进行编组的话。Otherwiseitcontains‘不’。此外,在输入文件的一个块对应的行之后还有一个空行。输出文件中没有与输入文件的最后一个“null”块对应的行。

Sample Input 5

1 2 3 4 5

5 4 1 2 3

0

6

6 5 4 3 2 1

0

0

Sample Output

Yes

No

Yes

模拟用stack模拟入栈出栈出栈为样例即可

#include<iostream>
#include<stack>
#include<queue>
#include<string.h>
using namespace std;
int a[10000];
int main()
{
	int n,u;
	while(1)
	{
		scanf("%d",&n);
		if(n == 0)
		{
			return 0;
		}
		while(1)
		{
			u=0;memset(a,0,sizeof(a));
			for(int i = 1;i <= n;i++)
			{
				scanf("%d",&a[i]);
				if(a[1] == 0)
				{
				u=1;break;	
				}
			}
			if(u == 1)
			{
				break;
			}
			stack<int>A;int j=1;
			for(int i=1;i<=n;i++)
			{
				A.push(i);
				while(A.top() == a[j])
				{
					A.pop();
					j++;
					if(A.empty())
					{
						break;
					}
				}
			}
			if(A.empty())
			{
				printf("Yes\n");
			}
			else{
				printf("No\n");
			}
			while(!A.empty())
			{
				A.pop();
			}
		}
		printf("\n");	
	}
	
	
	 
	return 0;
}

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

-lyslyslys

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值