Dynamic Programming?

Dynamic Programming, short for DP, is the favorite of iSea. It is a method for solving complex problems by breaking them down into simpler sub-problems. It is applicable to problems exhibiting the properties of overlapping sub-problems which are only slightly smaller and optimal substructure. 
Ok, here is the problem. Given an array with N integers, find a continuous subsequence whose sum’s absolute value is the smallest. Very typical DP problem, right? 

Input

The first line contains a single integer T, indicating the number of test cases. 
Each test case includes an integer N. Then a line with N integers Ai follows. 

Technical Specification 
1. 1 <= T <= 100 
2. 1 <= N <= 1 000 
3. -100 000 <= Ai <= 100 000 

Output

For each test case, output the case number first, then the smallest absolute value of sum.

Sample Input

2
2
1 -1
4
1 2 1 -2

Sample Output

Case 1: 0
Case 2: 1

题意:给你一段数组求你的连续的绝对值最小的序列并输出

思路:暴力枚举每一段

代码:

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath> 
#define inf 0x3f3f3f3f3f3f
using namespace std;
long long a[1000009],dp[1000009];
int main()
{
	long long t,n,min1;
	scanf("%lld",&t);
	long long g=1;
	while(t--)
	{
		min1 = inf;
		memset(dp,0,sizeof(dp));
		memset(a,0,sizeof(a));
		scanf("%lld",&n);
		for(long long i=1;i<=n;++i)
		{
			scanf("%lld",&a[i]);
			a[i] = a[i-1]+a[i];//存前几项和
		}
		for(long long i=1;i<=n;++i)
		{
			dp[i] = inf;
			for(long long j=0;j<i;++j)
			{
				dp[i] = min(dp[i],abs(a[i]-a[j]));//枚举每一段
			}
			min1 = min(dp[i],min1);
		}
		printf("Case %lld: %lld\n",g,min1);//输出
		g++;
	}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

-lyslyslys

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值