Acwing 1221. 四平方和

四平方和定理,又称为拉格朗日定理:

每个正整数都可以表示为至多 4 个正整数的平方和。

如果把 0 包括进去,就正好可以表示为 4 个数的平方和。

比如:

5=02+02+12+22
7=12+12+12+22
对于一个给定的正整数,可能存在多种平方和的表示法。

要求你对 4 个数排序:

0≤a≤b≤c≤d
并对所有的可能表示法按 a,b,c,d 为联合主键升序排列,最后输出第一个表示法。

输入格式
输入一个正整数 N。

输出格式
输出4个非负整数,按从小到大排序,中间用空格分开。

数据范围
0<N<5∗106
输入样例:
5
输出样例:
0 0 1 2

二分做法:

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
const int N=5000010;
int n,m,t;
struct Num{
    int s,c,d;
    bool operator < (const Num&t)const{
        if(s!=t.s) return s<t.s;
        if(c!=t.c) return c<t.c;
        return d<t.d;
    }
    
}Num[N];

int main(){
    cin>> n;
    for(int c=0;c*c<=n;c++){
        
        for(int d=c;d*d+c*c<=n;d++){
        
        Num[m++]={c*c+d*d,c,d};
        
        }
    }
    
    sort(Num,Num+m);
    
    for(int a=0;a*a<=n;a++){
        
        for(int b=0;b*b+a*a<=n;b++){
            
            int t=n-a*a-b*b;
            int l=0;
            int r=m;
            int mid;
            while(l<r){
                 mid=(l+r)/2;
                if(Num[mid].s >= t ) r=mid;
                else  l=mid+1;
            }
            if(Num[l].s==t){
                printf("%d %d %d %d",a,b,Num[l].c,Num[l].d);
                return 0;
            }
            
        }
    }
}

暴力做法:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>

using namespace std;
int N;
int main(){
    cin>>N;
    for( int a=0;a*a<=N;a++)
        for(int b=a;b*b+a*a<=N;b++)
            for(int c=b;c*c+b*b+a*a<=N;c++){
                int t=N-a*a-b*b-c*c;
                int d=sqrt(t);
                if(d*d==t){
                    printf("%d %d %d %d\n",a,b,c,d);
                    return 0;
                }
            
        }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值