PAT---A1118 Birds in Forest (25分)

题意

给出n张照片,每张照片有若干个鸟,假设一张照片中的鸟都在一棵树上,
要求输出树的数目和鸟的总数。并给出q个问题,每个问题询问两只鸟是否在一棵树上。

思路

典型并查集。
Sample Input:

4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7

Sample Output:

2 10
Yes
No
#include "bits/stdc++.h"
using namespace std;
const int N = 10005;
int father[N];
int findFather(int x){
    int a = x;
    while (father[x] != x)  x = father[x];
    while (a != x){
        int t = a;
        a = father[a];
        father[t] = x;
    }
    return x;
}
void _union(int a, int b){
    father[findFather(a)] = findFather(b);
}
int main(){
//     freopen("input.txt","r",stdin);
    int n; cin >> n;
    set<int> ids;
    for (int i = 0; i < N; ++i) father[i] = i;

    for (int i = 0; i < n; ++i) {
        int k; scanf("%d",&k);
        int head = -1;
        for (int j = 0; j < k; ++j) {
            int id; scanf("%d",&id); ids.insert(id);
            if (j == 0) head = id;
            else  _union(id,head);
        }
    }

    unordered_map<int,int> group;
    for(int id:ids) group[findFather(id)] ++;
    cout << group.size() << " " << ids.size() << endl;
    int q; cin >> q;
    for (int i = 0; i < q; ++i) {
        int a, b; scanf("%d%d",&a,&b);
        if (findFather(a) == findFather(b)) printf("Yes\n");
        else printf("No\n");
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值