【PAT甲级 - C++题解】1118 Birds in Forest

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1118 Birds in Forest (pintia.cn)
🔑中文翻译:森林里的鸟
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1118 Birds in Forest

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤104) which is the number of pictures. Then N lines follow, each describes a picture in the format:

K B1 B2 … BK

where K is the number of birds in this picture, and Bi’s are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 104.

After the pictures there is a positive number Q (≤104) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

Output Specification:

For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line Yes if the two birds belong to the same tree, or No if not.

Sample Input:

4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7

Sample Output:

2 10
Yes
No
题意

假设所有出现在同一张照片中的鸟都属于同一棵树,并给出所有照片。

请你帮助科学家计算森林中树木的最大数量,对于任何一对鸟类,请判断它们是否在同一棵树上。

思路

具体思路如下:

  1. 初始化并查集,然后输入每张照片中鸟的信息,并将该照片中的鸟合并到一个集合中去。
  2. 统计鸟的数量,并输出最大可能的树的数量以及鸟的数量。
  3. 进行查询操作,如果给定两只鸟的编号不在同一集合中则不属于同一棵树,否则属于同一棵树。
代码
#include<bits/stdc++.h>
using namespace std;

const int N = 10010;
int birds[10], p[N];
bool st[N];
int n, k, cnt;

//并查集查找模板
int find(int x)
{
    if (p[x] != x) p[x] = find(p[x]);
    return p[x];
}

int main()
{
    cin >> n;

    for (int i = 0; i < N; i++)    p[i] = i; //初始化并查集
    for (int i = 0; i < n; i++)    //合并每个集合
    {
        cin >> k;
        //先将编号保存起来
        for (int j = 0; j < k; j++)
        {
            cin >> birds[j];
            st[birds[j]] = true;
        }
        //进行并查集操作
        for (int j = 1; j < k; j++)
        {
            int a = birds[j - 1], b = birds[j];
            int pa = find(a), pb = find(b);
            if (pa != pb)
            {
                p[pa] = pb;
                cnt++;
            }
        }
    }

    //统计鸟的数量并输出最大可能的树的数量以及鸟的数量
    int total = 0;
    for (int i = 0; i < N; i++)    total += st[i];
    printf("%d %d\n", total - cnt, total);

    //进行查询操作
    cin >> k;
    while (k--)
    {
        int a, b;
        cin >> a >> b;
        int pa = find(a), pb = find(b);
        if (pa == pb)  puts("Yes");
        else    puts("No");
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值