POJ 1979 DFS

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
…#.
…#





#@…#
.#…#.
11 9
.#…
.#.#######.
.#.#…#.
.#.#.###.#.
.#.#…@#.#.
.#.#####.#.
.#…#.
.#########.

11 6
…#…#…#…
…#…#…#…
…#…#…###
…#…#…#@.
…#…#…#…
…#…#…#…
7 7
…#.#…
…#.#…
###.###
…@…
###.###
…#.#…
…#.#…
0 0

Sample Output

45
59
6
13

思路

普通的dfs遍历,不过无需在每种状态中进行记录数字,而是直接全局记录,如果在状态中记录cnt+1,代表的是当前这一个路径最多走的路程。

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int w,h,sx,sy;
char a[25][25];
bool b[25][25];
int ans;
int dx[]={0,-1,0,1};
int dy[]={1,0,-1,0};
bool check(int x,int y){
	if(x<=0||y<=0||x>h||y>w||b[x][y]||a[x][y]=='#')return false;
	return true;
}
void dfs(int x,int y){
	ans++;//重点,这里直接ans++,而不是通过状态cnt来进行max比较。
	b[x][y]=true;
	for(int i=0;i<4;i++){
		int tempX=x+dx[i];
		int tempY=y+dy[i];
		if(check(tempX,tempY)){
			dfs(tempX,tempY);
		}
	}
}
int main(){
	while(scanf("%d%d",&w,&h),w){
		for(int i=1;i<=h;i++){
			for(int j=1;j<=w;j++){
				cin >> a[i][j];
				if(a[i][j]=='@'){
					sx=i;
					sy=j;
				}
			}
		}
		memset(b,0,sizeof b);
		ans=0;
		dfs(sx,sy);
		cout << ans << endl;
	}
	return 0;
}

总结

对于需要统计点的状况,无需对于状态进行记录,只需要进行标记后++就可以了。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值