A - Anniversary party(树形DP)

28 篇文章 0 订阅
2 篇文章 0 订阅

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings. 

Input

There are several cases. In each case,Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Case is ended with the line 
0 0

Output

Output should contain the maximal sum of guests' ratings. 

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5
题意:多组输入,每组输入的第一行一个N代表N个人,接下来N行每行一个数代表如果这个人参加party的欢乐值,接下来许多行,每行两个数u,v 表示v是u的直接上属。举行一个party,如果邀请了这个人的直接上司就不能邀请这个人,要求最后总的欢乐值最大,问欢乐值最大为多少。
思路:开一个二维dp dp[x][0]代表没有邀请x的最大欢乐值、dp[x][1]代表邀请了x的最大欢乐值。初始化dp[x][0]均为0 dp[x][1]为a[x]。dfs从树根遍历这棵树。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<bitset>
#include<cassert>
#include<cctype>
#include<cmath>
#include<cstdlib>
#include<ctime>
#include<deque>
#include<iomanip>
#include<list>
#include<map>
#include<queue>
#include<set>
#include<stack>
#include<vector>
using namespace std;
typedef long long ll;
const double pi = acos(-1.0);
const ll mod = 1e9 + 7;
const int inf = 0x3f3f3f3f;
const int maxn = 6e3 + 50;
int a[maxn];
vector<int> ve[maxn];
int num[maxn];
int vis[maxn];
int dp[maxn][2];
void dfs(int x)
{
    dp[x][0] = 0;
    dp[x][1] = a[x];
    vis[x] = 1;
    for(auto it : ve[x])
    {
        int to = it;
        if(vis[to]) continue;
        dfs(to);
        dp[x][0] += max(dp[to][0], dp[to][1]);
        dp[x][1] += dp[to][0];
    }
    return ;
}
int main()
{
    int n;
    while(cin >> n)
    {
        memset(num, 0, sizeof(num));
        for(int i=1;i<=n;i++)
        {
            ve[i].clear();
        }
        for(int i=1;i<=n;i++)
        {
            cin >> a[i];
        }
        int u, v;
        while(cin >> u >> v)
        {
            if(!u && !v) break;
            ve[v].push_back(u);
            num[u]++;
        }
        memset(vis, 0, sizeof(vis));
        for(int i=1;i<=n;i++)
        {
            if(!num[i])
            {
                dfs(i);
                cout << max(dp[i][0], dp[i][1]) << endl;
                break;
            }
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值