PAT A1047 Student List for Course (25 分)

1047 Student List for Course (25 分)

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤40,000), the total number of students, and K (≤2,500), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (≤20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

此题和上一篇博客的题目刚好反过来,此题要求输出每门课的所有选课学生。利用一个向量数组sc存储每门课的选课学生,将每门课的学生输入,排序后输出。注意因是输出学生姓名,固向量应为string类型。但string输出必须要cin,和cout,这样会使最后一个测试用例超时。固转化为字符串格式输入输出。注意输出时用到了str.c_str()这个函数将string类型转化为c字符串数组进行输出。 

参考代码如下:

#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
using namespace std;
vector <string> sc[2510];
bool cmp(string name1,string name2)
{
	return name1<name2;
}
int main()
{
	int n,k;
	while(scanf("%d %d",&n,&k)!=EOF)
	{
		for(int i=0;i<n;++i)
		{
			char name[5];
			scanf("%s",name);
			int c;
			scanf("%d",&c);
			for(int j=0;j<c;++j)
			{
				int no;
				scanf("%d",&no);
				sc[no].push_back(name);
			}
		}
		for(int i=1;i<=k;++i)
		{
			sort(sc[i].begin(),sc[i].end());
			printf("%d %d\n",i,sc[i].size());
			for(int j=0;j<sc[i].size();++j)
				printf("%s\n",sc[i][j].c_str());
		}
	}
	return 0;
 } 

当然也可以利用hash的思想将name和course分别存储。

参考代码如下:

#include <iostream>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;
char name[40010][5];
vector <int> course[2510];
bool cmp(int a,int b)
{
	return strcmp(name[a],name[b])<0;
}
int main()
{
	int n,k,c,courseid;
	while(scanf("%d %d",&n,&k)!=EOF)
	{
		for(int i=0;i<n;++i)
		{
			scanf("%s %d",&name[i],&c);
			for(int j=0;j<c;++j)
			{
				scanf("%d",&courseid);
				course[courseid].push_back(i);
			}
		}
		for(int i=1;i<=k;++i)
		{
			sort(course[i].begin(),course[i].end(),cmp);
			printf("%d %d\n",i,course[i].size());
			for(int j=0;j<course[i].size();++j)
				printf("%s\n",name[course[i][j]]);
		}
	}
	return 0;
 } 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值