7.3 PAT A1097 Deduplication on a Linked List (25 分)(静态链表排序去重)

1097 Deduplication on a Linked List (25 分)

Given a singly linked list L with integer keys, you are supposed to remove the nodes with duplicated absolute values of the keys. That is, for each value K, only the first node of which the value or absolute value of its key equals K will be kept. At the mean time, all the removed nodes must be kept in a separate list. For example, given L being 21→-15→-15→-7→15, you must output 21→-15→-7, and the removed list -15→15.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, and a positive N (≤10​5​​) which is the total number of nodes. The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the position of the node, Key is an integer of which absolute value is no more than 10​4​​, and Next is the position of the next node.

Output Specification:

For each case, output the resulting linked list first, then the removed list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854

Sample Output:

00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1

 题意为给定一个序列,删除绝对值相同的多余元素,仅保留一个,输出删除后的链表及删除的链表。开始可以将每个结点的order初始化为2*maxn,表示无效结点,用一个exsit数组记录绝对值是否出现过。并用countvalid和countremoved记录保留和删除的节点数,并将保留的结点的顺序从0开始排序,删除的结点order从Maxn开始排序,在排序后,前面的结点即为保留的,随之便是删除的结点,最后说无效的结点。按要求输出即可。

参考代码如下:

#include <iostream>
#include <algorithm>
#include <string.h> 
using namespace std;
const int Maxn=100010;
const int tab=1000010;
struct Node{
	int data;
	int address;
	int next;
	int order;
}node[Maxn];
bool cmp(Node a,Node b)
{
	return a.order<b.order;
}
bool exsit[tab]={false};
int main()
{
	memset(exsit,false,sizeof(exsit));
	for(int i=0;i<Maxn;++i)
	{
		node[i].order=2*Maxn;
	}
	int n,head,address;
	scanf("%d%d",&head,&n);
	for(int i=0;i<n;++i)
	{
		scanf("%d",&address);
		scanf("%d%d",&node[address].data,&node[address].next);
		node[address].address=address;
	}
	int countv=0,countr=0;
	int p=head;
	while(p!=-1)
	{
		if(!exsit[abs(node[p].data)])
		{
			exsit[abs(node[p].data)]=true;
			node[p].order=countv++;
		}
		else
		{
			node[p].order=Maxn+countr++;
		}
		p=node[p].next;
	}
	sort(node,node+Maxn,cmp);
	int count=countv+countr;
	for(int i=0;i<count;++i)
	{
		if(i!=count-1&&i!=countv-1)
			printf("%05d %d %05d\n",node[i].address,node[i].data,node[i+1].address) ; 
		else
			printf("%05d %d -1\n",node[i].address,node[i].data ) ;
	}
	return 0;
 } 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值