PAT A1098 Insertion or Heap Sort (25 分)(插入排序还是堆排序)

1098 Insertion or Heap Sort (25 分)

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Heap Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9

Sample Output 2:

Heap Sort
5 4 3 1 0 2 6 7 8 9

判断给定序列是插入排序过程中产生的还是堆排序过程中产生的,并给出下一步操作的序列

参考代码:

#include <cstdio>
#include <algorithm>
using namespace std;
const int N=111;
int origin[N],temp[N],change[N];//初始,备份,以及目标数组 
int n;
bool issame(int a[],int b[])
{
	for(int i=1;i<=n;++i)
	{
		if(a[i]!=b[i])
			return false;
	}
	return true;
}
void showarray(int a[])//输出数组
{
	for(int i=1;i<=n;++i)
	{
		printf("%d",a[i]);
		if(i<n)
			printf(" ");
	}
	printf("\n");
}
bool insertsort()
{
	bool flag=false;//记录是否存在数组中间步骤与changed相同
	for(int i=2;i<=n;++i)//进行n-1趟排序 
	{
		if(i!=2&&issame(temp,change))
			flag=true; //中间步骤与初始序列相同,且不是初始序列
		//插入部分用sort代替
		sort(temp,temp+i+1);
		if(flag==true)
			return true; //如果flag=true,说明已达到目标数组 
	}
	return false;
}

void downadjust(int low,int high)
{
	int i=low,j=2*i;
	while(j<=high)
	{
		if(j+1<=high&&temp[j+1]>temp[j])
			j=j+1;
		if(temp[j]>temp[i])
		{
			swap(temp[j],temp[i]);
			i=j;
			j=2*i;
		}
		else
			break;
	}
}

void heapsort()
{
	bool flag=false;
	for(int i=n/2;i>=1;--i)
	{
		downadjust(i,n);//建堆 
	}
	for(int i=n;i>1;--i)
	{
		if(i!=n&&issame(temp,change))
			flag=true;
		swap(temp[i],temp[1]);//交换temp[i]与堆顶 
		downadjust(1,i-1);
		if(flag==true)
		{
			showarray(temp);
			return;
		 } 
	 } 
}
int main()
{
	scanf("%d",&n);
	for(int i=1;i<=n;++i)
	{
		scanf("%d",&origin[i]);
		temp[i]=origin[i];
	}
	for(int i=1;i<=n;++i)
	{
		scanf("%d",&change[i]);
	}
	if(insertsort()==true)
	{
		printf("Insertion Sort\n");
		showarray(temp);
	}
	else
	{
		printf("Heap Sort\n");
		for(int i=1;i<=n;++i)
		{
			temp[i]=origin[i];//还原temp数组 
		}
		heapsort(); 
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值