10.4 PAT A1003 Emergency (25 分)(最短路径及最大点权——Bellman算法实现)

1003 Emergency (25 分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1​​ and C​2​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1​​, c​2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2​​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

参考代码:

#include <cstdio>
#include <cstring>
#include <vector>
#include <set>
#include <algorithm>
using namespace std;
const int maxv=520;
const int INF=0x3fffffff;
struct node{
	int v,dis;
	node(int _v,int _dis): v(_v) ,dis(_dis) //构造函数 
	{}
}; 
vector<node> G[maxv];

int n,m,start,End,weight[maxv]; 
//n为顶点数,m为边数,start和End分别为起点和终点,wieght[]记录点权
int d[maxv],w[maxv],num[maxv];
//d[]记录最短距离,w[]记录最大点权之和,num[]记录最短路径条数
set<int> pre[maxv]; //前驱

void Bellman(int s)
{
	fill(d,d+maxv,INF);
	memset(num,0,sizeof(num));
	memset(w,0,sizeof(w));
	d[s]=0;
	w[s]=weight[s];
	num[s]=1;
	//以下为求解数组d的部分
	for(int i=0;i<n-1;++i)
	{
		for(int u=0;u<n;++u)
		{
			for(int j=0;j<G[u].size();++j)
			{
				int v=G[u][j].v ;
				int dis=G[u][j].dis;
				if(d[u]+dis<d[v])//以u为中介点可以使d[v]更小
				{
					d[v]=d[u]+dis; //更新d[v]
					w[v]=w[u]+weight[v]; //更新w[v] 
					num[v]=num[u];
					pre[v].clear();
					pre[v].insert(u);
				}
				else if(d[u]+dis==d[v])
				{
					if(w[u]+weight[v]>w[v]) //以u为中介点时点权之和更大 
						w[v]=w[u]+weight[v]; //w[v]继承自w[u] 
					pre[v].insert(u); //将u加入pre 
					num[v]=0; //重新统计num[v] 
					set<int> ::iterator it;
					for(it=pre[v].begin();it!=pre[v].end();++it)
					{
						num[v]+=num[*it];
					}
				}
			}
		}
	 } 
 } 
 
 int main()
 {
 	scanf("%d%d%d%d",&n,&m,&start,&End);
 	for(int i=0;i<n;++i)
 		scanf("%d", &weight[i]);
	int u,v,wt;
	for(int i=0;i<m;++i)
	{
		scanf("%d%d%d",&u,&v,&wt);
		G[u].push_back(node(v,wt));
		G[v].push_back(node(u,wt));
	}
	Bellman(start);
	printf("%d %d\n",num[End],w[End]);
	return 0; 
 }

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值