6.4 PAT A1071 Speech Patterns (25分)(字符串分割&map使用)

1071 Speech Patterns (25分)

People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

Input Specification:

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return \n. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

Output Specification:

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

Sample Input:

Can1: "Can a can can a can?  It can!"

 

Sample Output:

can 5

题意为求给定字符串中单词出现次数最多的单词。注意单词不区分大小写,以小写形式输出。字母和数字是构成单词的合法字符。

注意分割字符串的方法,以及map使用是格式的书写。

参考代码:

#include <iostream>
#include <map>
#include <string>
using namespace std;
bool check(char c)
{
	if((c>='0'&&c<='9')||(c>='a'&&c<='z')||(c>='A'&&c<='Z'))
		return true;
	else
		return false;
}
map<string,int> count;
int main()
{
	string s;
	while(getline(cin,s))
	{
		int len=s.length();
		int i=0;
		while(i<len)  //字符串分割处理 
		{
			string word;
			while(i<len&&check(s[i]))
			{
				if(s[i]>='A'&&s[i]<='Z')
					s[i]+=32; //转化为小写字母 
				word+=s[i]; //加到字符串后 
				++i;
			}
			if(word!="")
				count[word]++;  
			while(i<len&&check(s[i])==false) //跳过非字符 
				++i;
		}
		string k;
		int Max=0;
		for(map<string,int>::iterator it=count.begin();it!=count.end();++it)
		{
			if(it->second>Max)
			{
				k=it->first;  //获取第一关键字 即字符串 
				Max=it->second;  //获取第二关键字,即次数 
			}
		}
		cout<<k<<" "<<Max<<endl; 
	}
	return 0;
 } 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值