1030 Travel Plan (30 分)

1030 Travel Plan (30 分)

A traveler’s map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.
Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (≤500) is the number of cities (and hence the cities are numbered from 0 to N−1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input:

4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20

Sample Output:

0 2 3 3 40

这题是对Dij算法的简单变形,相当于又加了一层标尺,既要判断最短路还要判断如果路径长度一样再去判断花费是否最小,既要求最短路径还需要最小花费,在记录路径时设置一个r数组每次标记他的父节点,最后递归输出即可。
#include<bits/stdc++.h>

using namespace std;

const int maxn = 1e4+5;
const int inf = 0x3f3f3f3f;
int dis[maxn],c[maxn],r[maxn];
bool vis[maxn];
int st,ed,n,m;

struct node
{
	int u,w,val;
	node(int uu , int ww , int vall):u(uu),w(ww),val(vall){}
	friend bool operator <(node a , node b)
	{
		return a.w > b.w;
 	} 
};
vector<node>e[maxn];
priority_queue<node>pque;

void add_edge(int u , int v , int w , int val)
{
	e[u].push_back(node(v,w,val));
}
void Dij(int st , int ed)
{
	fill(vis,vis+maxn,false);
	fill(dis,dis+maxn,inf);
	fill(c,c+maxn,inf);
	c[st] = 0;
	dis[st] = 0;
	pque.push(node(st,0,0));
	while(!pque.empty())
	{
		node t = pque.top();
		pque.pop();
		int u = t.u;
		if(vis[u])
			continue;
		vis[u] = true;
		for(int i = 0 ; i < e[u].size() ; i++)
		{
			int v = e[u][i].u;
			int w = e[u][i].w;
			int val = e[u][i].val;
			if(!vis[v] && dis[v] > dis[u] + w)
			{
				dis[v] = dis[u] + w;
				r[v] = u;
				c[v] = c[u] + val;
				pque.push(node(v,dis[v],c[v]));
			}
			else if(!vis[v] && dis[v] == dis[u] + w)
			{
				if(c[v] > c[u] + val)
				{
					c[v] = c[u] + val;
					r[v] = u;
					pque.push(node(v,dis[v],c[v]));
				}
			}
		}
	}
}

void prinf(int x)
{
	if(x == st)
	{
		cout << x << " ";
		return;
	}
	prinf(r[x]);
	cout << x << " ";
}

int main()
{
	cin >> n >> m >> st >> ed;
	for(int i = 0 ; i < m ; i++)
	{
		int u,v,w,val;
		cin >> u >> v >> w >> val;
		add_edge(u,v,w,val);
		add_edge(v,u,w,val);
	}
	Dij(st,ed);
	prinf(ed);
	cout << dis[ed] << " " << c[ed] << endl;
	return 0;
} 
1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。、可私 6信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 、可私信6博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 、可私信6博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

柠檬ya

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值