伪素数判断----Pseudoprime numbers

伪素数定义:伪素数,又叫做伪质数:它满足费马小定理,但其本身却不是素数。最小的伪素数是341。有人已经证明了伪素数的个数是无穷的。事实上,费马小定理给出的是关于素数判定的必要非充分条件。若n能整除2^(n-1)-1,并n是非偶数的合数,那么n就是伪素数。第一个伪素数341 是萨鲁(Sarrus)在1819年发现的。
简单解释一下伪素数:一个数字p本身不是素数但满足费马小定理,即a的p次方模p与a模p同余。

下面看具体题目:

Pseudoprime numbers

Fermat’s theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-a pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)
Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.

Input

Input contains several test cases followed by a line containing “0 0”. Each test case consists of a line containing p and a.

Output

For each test case, output “yes” if p is a base-a pseudoprime; otherwise output “no”.

Sample Input

3 2
10 3
341 2
341 3
1105 2
1105 3
0 0

Sample Output

no
no
yes
no
yes
yes

题目大意:给出p,a,判断p是否为伪素数 ,如果是输出yes否则输出no

AC代码:

#include <iostream>
#include <cstring>
#include <cmath>
#include <cstdio>


using namespace std;

typedef long long LL;
const int maxm = 1e6;
LL mod;


LL qmod(LL p , LL q)		//快速幂算法求a的p次方
{
	LL ans = 1;
	while(q)
	{
		if(q&1)
			ans = (p*ans) % mod;
		p = (p * p) % mod;
		q >>= 1;
	}
	return ans;
}


bool isprime(int n)
{
	for(int i = 2 ; i <= (int)sqrt(n) ; i++)
	{
		if(n % i == 0)
			return false;
	}
	return true;
}

int main()
{
	int a,p;
	while(cin >> p >> a)
	{
		if(a == 0 && p == 0)
			break;
		if(isprime(p))	//首先判断是否是素数
		{
			cout << "no" << endl;
			continue;
		}
		else
		{
			mod = p;
			if(qmod(a,p) == a % p) 	//判断费马小定律
			{
				cout << "yes" << endl;				
			}
			else
				cout << "no" << endl;
		}
			
	}
	return 0;
}
  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

柠檬ya

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值