1049 Counting Ones (30分)
The task is simple: given any positive integer N, you are supposed to count the total number of 1’s in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1’s in 1, 10, 11, and 12.
Input Specification:
Each input file contains one test case which gives the positive N (≤230).
Output Specification:
For each test case, print the number of 1’s in one line.
Sample Input:
12
Sample Output:
5
这题直接暴力的话会超时,但是找到规律的话复杂度为O(1)具体规律如下,参考编程之美
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
ll n;
int main()
{
cin >> n;
ll now,hnum,lnum;
ll a = 1,ans = 0;
while(n/a)
{
lnum = n % a;
now = n/a%10;
hnum = n/(a*10);
if(now == 0)
ans += hnum*a;
else if(now == 1)
ans += hnum*a + lnum + 1;
else
ans += (hnum+1)*a;
a *= 10;
}
cout << ans << endl;
return 0;
}