HDU1010 Tempter of the Bone DFS+剪枝

题目描述
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.
The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:
‘X’: a block of wall, which the doggie cannot enter;
‘S’: the start point of the doggie;
‘D’: the Door; or
‘.’: an empty block.
The input is terminated with three 0’s. This test case is not to be processed.

Output
For each test case, print in one line “YES” if the doggie can survive, or “NO” otherwise.
Sample Input
4 4 5
S.X.
…X.
…XD

3 4 5
S.X.
…X.
…D
0 0 0

Sample Output

NO
YES

题目大意:从这个迷宫中在指定正好的时间从S到达D处(注意!不是这个时间内,本英语菜鸡没有读懂题目理解错误导致各种WA重新认真看了才会)
然后我在改了之后,TL了,这时候才想起来要用剪枝,汗。
其实条件是非常好列的。
1.遇到墙就返回
2.到达时间点却不在门那
3.出了迷宫范围
还有最最重要的!奇偶剪枝,大意就是搞个图每个1相邻都是0,如果一个在1一个在0而时间是偶数,那么我们不可能在指定时间到达门 非常的好理解dei不dei!
那么废话不多说,上代码


**#include<iostream>
#include<cstdio>
using namespace std;
struct mazedata{
int used;
char data;
int count;
}maze[8][8];
int T,start,END,N,M,flag;
void dfs(int n,int m, int count)
{
	int i,j,a[4]={0,0,1,-1},b[4]={1,-1,0,0};
	char t=maze[n][m].data;
	if(n<0||m<0||n>=N||M<=m||flag)return;
	if(maze[n][m].used||maze[n][m].data=='X')return;
	else if(count+1==T&&maze[n][m].data=='D'){flag=1;return;}
	else if(count+1==T&&maze[n][m].data!='D')return;
	maze[n][m].used=1;
	maze[n][m].count=count+1;
	for(i=0;i<=3;i++)
	{maze[n][m].data='X';dfs(n+a[i],m+b[i],maze[n][m].count);maze[n][m].data=t;}
	if(flag==0)
	{
		maze[n][m].count=0;
		maze[n][m].used=0;
	return;
	}
}
int main()
{
int i,j;
while(scanf("%d %d %d",&N,&M,&T)!=EOF)
{
	flag=0;
if(N==0&&M==0&&T==0)break;
for(i=0;i<N;i++)
	for(j=0;j<M;j++){
		if(j==0)scanf(" %c",&maze[i][j].data);//注意输入格式!!不敢你会发现第一个会输入换行符号。。。emmm
		else scanf("%c",&maze[i][j].data);
		if(maze[i][j].data=='S'){start=i*10+j;}//这里是懒得用两个变量来记录用了点小聪明用一个变量= =
			if(maze[i][j].data=='D'){END=i*10+j;}
}
	if((END/10+start/10+END%10+start%10+T)%2==1)
          {
             printf("NO\n");
              continue;
          }
dfs(start/10,start%10,-1);
if(flag)printf("YES\n");
else printf("NO\n");
for(i=0;i<N;i++)
	for(j=0;j<M;j++)
	{maze[i][j].data='\0';maze[i][j].used=0;maze[i][j].count=0;}
}
return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值