BFS

Problem Description
可怜的公主在一次次被魔王掳走一次次被骑士们救回来之后,而今,不幸的她再一次面临生命的考验。魔王已经发出消息说将在T时刻吃掉公主,因为他听信谣言说吃公主的肉也能长生不老。年迈的国王正是心急如焚,告招天下勇士来拯救公主。不过公主早已习以为常,她深信智勇的骑士LJ肯定能将她救出。
现据密探所报,公主被关在一个两层的迷宫里,迷宫的入口是S(0,0,0),公主的位置用P表示,时空传输机用#表示,墙用*表示,平地用.表示。骑士们一进入时空传输机就会被转到另一层的相对位置,但如果被转到的位置是墙的话,那骑士们就会被撞死。骑士们在一层中只能前后左右移动,每移动一格花1时刻。层间的移动只能通过时空传输机,且不需要任何时间。

Input
输入的第一行C表示共有C个测试数据,每个测试数据的前一行有三个整数N,M,T。 N,M迷宫的大小NM(1 <= N,M <=10)。T如上所意。接下去的前NM表示迷宫的第一层的布置情况,后N*M表示迷宫第二层的布置情况。

Output
如果骑士们能够在T时刻能找到公主就输出“YES”,否则输出“NO”。

Sample Input
1 5 5 14 S*#*. .#… … **. …#. ….P #.… **… …. *.#…

Sample Output
YES

ac代码:

#include<queue>
#include<math.h>
#include<algorithm>
#include<string>
#include<string.h>
#include<stdio.h>
#include<iostream>

using namespace std;
#define N 112345678
#define M 155
#define INF 0x3f3f3f3f
struct node
{
    int x,y,time;
    bool flag;
}p,st;

int n, m, a, b, x, y, t, cnt, ans;
int dx[] = {0, 0, 1, -1};
int dy[] = {1, -1, 0, 0};
char mat1[M][M],mat2[M][M];
bool v1[M][M],v2[M][M];

void Bfs(int x, int y , int time)
{
    ans = -1;
    memset(v1,0,sizeof(v1));
    memset(v2,0,sizeof(v2));
    queue<node>q;
    while(!q.empty()) q.pop();

    st.x = x, st.y = y, st.time = time; st.flag = true;
    q.push(st);
    v1[st.x][st.y] = true;
    while(!q.empty())
    {
        st = q.front();
        //printf("front = %d %d    time = %d, flag = %d\n",st.x, st.y, st.time, st.flag);
        q.pop();
        for(int i = 0; i < 4; i++)
        {
            node next = st;
            next.x += dx[i], next.y += dy[i], next.time++;
            if(next.flag == true)
            {
                if(mat1[next.x][next.y] == 'P')
                {
                    ans = next.time ;
                    return;
                }
                if(next.x < 0 || next.x >= n || next.y < 0 || next.y >=m)continue;
                if(mat1[next.x][next.y] == '*' || mat1[next.x][next.y] == '#'&&mat2[next.x][next.y] == '*' || v1[next.x][next.y] == true || mat1[next.x][next.y] == '#'&&mat2[next.x][next.y] == '#') continue;
                if(mat1[next.x][next.y] == '#' )
                {
                    next.flag = !next.flag;
                }
                v1[next.x][next.y] = true;
            }
            if(next.flag == false)
            {
                if(mat2[next.x][next.y] == 'P')
                {
                    ans = next.time ;
                    return;
                }
                if(next.x < 0 || next.x >= n || next.y < 0 || next.y >=m)continue;
                if(mat2[next.x][next.y] == '*' || mat2[next.x][next.y] == '#'&&mat1[next.x][next.y] == '*' || v2[next.x][next.y] == true || mat1[next.x][next.y] == '#'&&mat2[next.x][next.y] == '#') continue;
                if(mat2[next.x][next.y] == '#' )
                {
                    next.flag = !next.flag;
                }
                v2[next.x][next.y] = true;
            }
            q.push(next);
        }
    }
}

int main()
{
    int T;cin>>T;
    while(T--)
    {
        cin>>n>>m>>t;
        for(int i = 0; i < n; i++)
            for(int j = 0; j < m; j++)
                scanf(" %c", &mat1[i][j]);
        for(int i = 0; i < n; i++)
            for(int j = 0; j < m; j++)
                scanf(" %c", &mat2[i][j]);

        Bfs(0,0,0);
        if(ans == -1 || ans > t)
            cout<<"NO"<<endl;
        else  cout<<"YES"<<endl;

    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值