PAT甲级 1003 Emergency (25 分) ——Dijkstra算法

PAT甲级 1003 Emergency (25 分) ——Dijkstra算法

一、题目要求

1003 Emergency (25 分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1 

Sample Output:

2 4

二、题目分析

本题是一道比较经典的Dijkstra算法题,附加项、考察的点也比较全,故写一篇题解记录一下。

需要注意的点有:

  • 声明
    • 结构体、所求(最短路径条数、点权最值)、已知条件(点权、点的个数)
    • 路径存储:邻接表、邻接矩阵
  • Dijkstra函数实现
    • 初始化:注意vis集合是在找到min、u的值后才加入新节点
    • 循环:注意更新条件和操作一一对应
  • main
    • 无向图存储时要对称存
#define _CRT_SECURE_NO_WARNINGS
#include<cstdio>
#include<vector>
using namespace std;
int n, rnum, from, to;
const int INF = 1000000000;
vector<int>res;		//题目给的点权(救援队数目)
struct node {
	int id;
	int len;
};
vector<node>adj[510];		//邻接矩阵
bool vis[510] = { false };//已访问的点的集合
int d[510] = { 0 };//最短路径结果
int resnum[510] = { 0 };//救援人数结果
int num[510] = { 0 };//最短路径条数
void dijkstra(int st)
{
	//初始化阶段
	fill(d, d + 510, INF);
	for (int i = 0;i < n;i++)
	{
		resnum[i] = res[i];
	}
	d[st] = 0;
	num[st] = 1;
	//扩充访问集合
	for (int i = 0;i < n;i++)
	{
		int min = INF, u = -1;
		for (int j = 0;j < n;j++)		//寻找没加入集合且距离最近的结点加入访问集合
		{
			if (d[j] < min&&vis[j]==false)
			{
				min = d[j];
				u = j;
			}
		}
		if (u == -1)		//找不到,说明不连通,直接退出
			return;
		vis[u] = true;//找到后才加入集合
		for (int k = 0;k < adj[u].size();k++)
		{
			int id = adj[u][k].id;
			int len = adj[u][k].len;
			if (vis[id] == false)		//加入集合的已经最短,故只对未访问节点操作
			{
				if (d[u] + len < d[id])		//用新加入的节点更新未访问的现有节点
				{
					d[id] = d[u] + len;
					resnum[id] = resnum[u] + res[id];
					num[id] = num[u];
				}
				else if (d[u] + len == d[id])
				{
					if(resnum[id] < resnum[u] + res[id])//注意路径个数和救援队数量无关,故路径个数更新写在条件外
						resnum[id] = resnum[u] + res[id];
					num[id] += num[u];
				}
			}
		}
	}
	
}
int main()
{
	scanf("%d%d%d%d", &n, &rnum, &from, &to);
	for (int i = 0;i < n;i++)
	{
		int resnum;
		scanf("%d", &resnum);
		res.push_back(resnum);
	}
	for (int i = 0;i < rnum;i++)
	{
		int a, b, len;
		scanf("%d%d%d", &a, &b, &len);
		node newn1,newn2;
		newn1.id = b;
		newn1.len = len;
		newn2 = newn1;
		newn2.id = a;
		adj[a].push_back(newn1);
		adj[b].push_back(newn2);		//邻接矩阵存无向图要对称存
	}
	dijkstra(from);
	printf("%d %d", num[to], resnum[to]);
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值