A-Lovers【暑假训练赛2】

Description

One day n girls and n boys come to Xi’an to look for a mate. Each girl has a value a[i], each boy has a value b[i]. Girl i and boy j will fall in love only if a[i] + b[j] ≥ k.
Please help them make pairs as many as possible.

Input

Several test cases .
First line an integer T (1 ≤ T ≤ 10). Indicates the number of test cases.
Then T test cases follows. Each test case begins with two integer N, K (1 ≤ N ≤ 200000,0 ≤ K ≤ 109). The next line has N integers indicate a[1] to a[N] (0 ≤ a[i] ≤ 10^9). The next line has N integers indicate b[1] to b[N] (0 ≤ b[i] ≤ 10^9)

Output

For each test case, print the answer in a single line.

Sample Input

1
3 4
1 2 3
1 2 3

Sample Output

3

Code

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn=200000+10;
int a[maxn];
int b[maxn];

int main(){
    int t;
    cin>>t;
    while(t--){
        int n,k;
        cin>>n>>k;
        for(int i=0;i<n;i++){
            scanf("%d",&a[i]);
            getchar();
        }
        for(int i=0;i<n;i++){
            scanf("%d",&b[i]);
            getchar();
        }
        sort(a,a+n);  
        sort(b,b+n);  
        if(a[n-1]+b[n-1]<k){
            printf("0\n");
            continue;
        }
		int j=0,num=0;
        for(int i=n-1;i>=0;i--){
            for(;j<n;j++){
                if(a[j]+b[i]==k){
                    num++;
					j=j+1;
					break;
                }
            }
        }
        printf("%d\n",num);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值