Catch That Cow(广搜应用)

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

题意:抓牛。农夫的牛跑了,农夫在x处,牛在y处,并且这个牛还不知道跑,农夫可以有三种走法:x->2*x, x->x-1 , x->x+1。问求一种走法,使农夫花费更少的时间抓住牛。

思路:一上来的想法是找找规律,却只发现,当y<x时x-y时最少的走法,剩下的得用搜索,深搜的话,很简单,但递归起来,那可就利索了,万一一条路不行它还一直不到底,直接就不行啊。那么可以用广搜,不断向外扩展。
不过这里数据很坑啊,没提示多组输入就算了,说好的十万,却存在超范围的数。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
struct node{
	int x,step;
}q[200010];
int book[200010];
int head,tail,n,k;
void bfs(int n)
{
	q[tail].x=n;
	q[tail].step=0;
	book[n]=1;
	tail++;
	int flag=0;
	while(head<tail)
	{
		int t;
		t=q[head].x-1;
		if(t>=0&&t<=200000&&book[t]==0)
		{
			q[tail].x=t;
			book[t]=1;
			q[tail].step=q[head].step+1;
			tail++;
			if(t==k) flag=1;
		}
		t=q[head].x+1;
		if(t>=0&&t<=200000&&book[t]==0)
		{
			q[tail].x=t;
			book[t]=1;
			q[tail].step=q[head].step+1;
			tail++;
			if(t==k) flag=1;
		}
		t=q[head].x*2;
		if(t>=0&&t<=200000&&book[t]==0)
		{
			q[tail].x=t;
			book[t]=1;
			q[tail].step=q[head].step+1;
			tail++;
			if(t==k) flag=1;
		}
		if(flag) break;
		head++;
	}
	return ;
}
int main()
{
	while(scanf("%d%d",&n,&k)!=EOF)
	{
		memset(book,0,sizeof(book));
		head=1;
		tail=1;
		if(n>=k) printf("%d\n",n-k);
		else 
		{
			bfs(n);
			printf("%d\n",q[tail-1].step);
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值