HDU 1251 统计难题 (字典树)

Problem Description

Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).

 

Input

输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.

 

Output

对于每个提问,给出以该字符串为前缀的单词的数量.

 

Sample Input

banana

band

bee

absolute

acm

ba

b

band

abc

 

Sample Output

2

3

1

0

统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).增加一个sum数组把到一个节点 (以该节点为尾的字符串作为前缀) 的字符数存储起来。

AC代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>
#include<stdlib.h>
#include<queue>
#include<map>
#include<iomanip>
#include<math.h>
using namespace std;
typedef long long ll;
typedef double ld;
using namespace std;
const ll inf=0x3f3f3f3f;
const int maxn=2e6+5;
int tree[maxn][30],sum[maxn],tot=0;
void add(char *s)
{
    int len=strlen(s);
    int root=0;
    for(int i=0; i<len; ++i)
    {
        int id=s[i]-'a';
        if(!tree[root][id])
            tree[root][id]=++tot;
        sum[tree[root][id]]++;
        root=tree[root][id];
    }
}
ll find(char *s)
{
    ll res=0;
    int root=0,len=strlen(s);
    for(int i=0; i<len; ++i)
    {
        int id=s[i]-'a';
        if(!tree[root][id])
            return 0;
        root=tree[root][id];
    }
    return sum[root];
}
char tp[maxn];
int main()
{
    std::ios::sync_with_stdio(0);
    while(gets(tp))
    {
        if(tp[0]=='\0')
            break;
        add(tp);
    }
    while(scanf("%s",tp)!=EOF)
    {
        printf("%lld\n",find(tp));
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值