UVA 10061 进制问题

Description:

Given a decimal integer number you will have to find out how many trailing zeros will be there in its
factorial in a given number system and also you will have to find how many digits will its factorial have
in a given number system? You can assume that for a b based number system there are b different
symbols to denote values ranging from 0... b − 1. 0 . . . b − 1. 0...b1.

Input

There will be several lines of input. Each line makes a block. Each line will contain a decimal number
N (a 20bit unsigned number) and a decimal number B ( 1 < B ≤ 800 ) B (1 < B ≤ 800) B(1<B800), which is the base of the number
system you have to consider. As for example 5 ! = 120 5! = 120 5!=120 (in decimal) but it is 78 in hexadecimal number
system. So in Hexadecimal 5 ! 5! 5! has no trailing zeros.

Output

For each line of input output in a single line how many trailing zeros will the factorial of that number
have in the given number system and also how many digits will the factorial of that number have in
that given number system. Separate these two numbers with a single space. You can be sure that the
number of trailing zeros or the number of digits will not be greater than 2 31 − 1 2^{31} − 1 2311.

Sample Input

2 10
5 16
5 10

Sample Output

0 1
0 2
1 3

题意:

题目大意:让求 n ! n! n b a s e base base进制下的位数以及末尾 0 0 0 的连续个数。

  • 多少位

l o g 10 256 = l o g 10 21 0 2 + l o g 10 51 0 1 + l o g 10 6 ∗ 1 0 0 log_{10}256=log_{10}210^2+log_{10}510^1+log_{10}6*10^0 log10256=log102102+log105101+log106100

可以发现,只和最高位有关,要想进位必须有 1 0 3 10^3 103 ,那么通解:

数值 a a a b b b 进制下的位数为: f l o o r ( l o g b a ) + 1 floor(log_ba)+1 floor(logba)+1

这里是阶乘化简: l o g b n ! = l o g b 1 + l o g b 2 + . . . + l o g b n log_bn!=log_b1+log_b2+...+log_bn logbn!=logb1+logb2+...+logbn

  • 末尾有多少个0

可以考虑, 123456789 ( 25 ) . . . ( 5 ∗ 600 ) 123456789(25)...(5*{600}) 123456789(25)...(5600)

即进制的最大质因数,都多少个?

这里首先就有 600 600 600 个,注意是 51 , 52 , 53 , 54 , . . . , 5 ∗ 600 51,52,53,54,...,5*{600} 51,52,53,54,...,5600 600 600 600 个,

但是可以发现 600 600 600,也可以分解:于是就有: 51 , 52 , 53 , 54 , . . . , 5 ∗ 600 51,52,53,54,...,5*{600} 51,52,53,54,...,5600

即: 1 , 2 , 3 , 4 , 5 , 6 , . . . , 600 1,2,3,4,5,6,...,600 1,2,3,4,5,6,...,600

依次地推下去。

最后要注意的是如果进制 b b b 最大质因数有 k k k 个,那么结果要 / k / k /k,因为必须是整除 b b b 进制。

AC 代码:
#include <cstdio>
#include <vector>
#include <queue>
#include <cstring>
#include <cmath>
#include <map>
#include <set>
#include <string>
#include <iostream>
#include <algorithm>
#include <iomanip>
#include <stack>
#include <queue>
using namespace std;
#define sd(n) scanf("%d", &n)
#define sdd(n, m) scanf("%d%d", &n, &m)
#define sddd(n, m, k) scanf("%d%d%d", &n, &m, &k)
#define pd(n) printf("%d\n", n)
#define pc(n) printf("%c", n)
#define pdd(n, m) printf("%d %d\n", n, m)
#define pld(n) printf("%lld\n", n)
#define pldd(n, m) printf("%lld %lld\n", n, m)
#define sld(n) scanf("%lld", &n)
#define sldd(n, m) scanf("%lld%lld", &n, &m)
#define slddd(n, m, k) scanf("%lld%lld%lld", &n, &m, &k)
#define sf(n) scanf("%lf", &n)
#define sc(n) scanf("%c", &n)
#define sff(n, m) scanf("%lf%lf", &n, &m)
#define sfff(n, m, k) scanf("%lf%lf%lf", &n, &m, &k)
#define ss(str) scanf("%s", str)
#define rep(i, a, n) for (int i = a; i <= n; i++)
#define per(i, a, n) for (int i = n; i >= a; i--)
#define mem(a, n) memset(a, n, sizeof(a))
#define debug(x) cout << #x << ": " << x << endl
#define pb push_back
#define all(x) (x).begin(), (x).end()
#define fi first
#define se second
#define mod(x) ((x) % MOD)
#define gcd(a, b) __gcd(a, b)
#define lowbit(x) (x & -x)
typedef pair<int, int> PII;
typedef long long ll;
typedef unsigned long long ull;
typedef long double ld;
const int MOD = 1e9 + 7;
const double eps = 1e-9;
const ll INF = 0x3f3f3f3f3f3f3f3fll;
const int inf = 0x3f3f3f3f;
inline int read()
{
	int ret = 0, sgn = 1;
	char ch = getchar();
	while (ch < '0' || ch > '9')
	{
		if (ch == '-')
			sgn = -1;
		ch = getchar();
	}
	while (ch >= '0' && ch <= '9')
	{
		ret = ret * 10 + ch - '0';
		ch = getchar();
	}
	return ret * sgn;
}
inline void Out(int a)
{
	if (a > 9)
		Out(a / 10);
	putchar(a % 10 + '0');
}

ll gcd(ll a, ll b)
{
	return b == 0 ? a : gcd(b, a % b);
}

ll lcm(ll a, ll b)
{
	return a * b / gcd(a, b);
}
///快速幂m^k%mod
ll qpow(ll a, ll b, ll mod)
{
	if (a >= mod)
		a = a % mod + mod;
	ll ans = 1;
	while (b)
	{
		if (b & 1)
		{
			ans = ans * a;
			if (ans >= mod)
				ans = ans % mod + mod;
		}
		a *= a;
		if (a >= mod)
			a = a % mod + mod;
		b >>= 1;
	}
	return ans;
}

// 快速幂求逆元
int Fermat(int a, int p) //费马求a关于b的逆元
{
	return qpow(a, p - 2, p);
}

///扩展欧几里得
ll exgcd(ll a, ll b, ll &x, ll &y)
{
	if (b == 0)
	{
		x = 1;
		y = 0;
		return a;
	}
	ll g = exgcd(b, a % b, x, y);
	ll t = x;
	x = y;
	y = t - a / b * y;
	return g;
}

int slove(int n, int b)
{
	int i, d, m, t;
	for (i = 2, d = 1; i <= b; i++)
	{
		m = 0;
		while (b % i == 0)
		{
			m++;
			d = i; //最大质因数
			b /= i;
		}
	}

	for (t = 0; n > 0;)
	{
		t += n / d;
		n /= d;
	}
	return t / m;
}

int main()
{
	int n, b;
	while (~sd(n,b))
	{

		double l = 0;
		rep(i,2,n)
		{
			l += log10(i) / log10(b);
		}
		l++;
		int ans1 = floor(l);
		int ans2 = slove(n, b);
		pdd(ans2, ans1);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值