POJ1862 Stripies题解

为什么要总结这道题,因为是今天刚刚做出来,然后也用到了贪心的思路,其实题不难就是来记录一下自己对贪心这种思维的运用。

Description

Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian - polosatiki, but the scientists had to invent an English name to apply for an international patent). The stripies are transparent amorphous amebiform creatures that live in flat colonies in a jelly-like nutrient medium. Most of the time the stripies are moving. When two of them collide a new stripie appears instead of them. Long observations made by our scientists enabled them to establish that the weight of the new stripie isn’t equal to the sum of weights of two disappeared stripies that collided; nevertheless, they soon learned that when two stripies of weights m1 and m2 collide the weight of resulting stripie equals to 2sqrt(m1m2). Our chemical biologists are very anxious to know to what limits can decrease the total weight of a given colony of stripies.
You are to write a program that will help them to answer this question. You may assume that 3 or more stipies never collide together.
Input

The first line of the input contains one integer N (1 <= N <= 100) - the number of stripies in a colony. Each of next N lines contains one integer ranging from 1 to 10000 - the weight of the corresponding stripie.
Output

The output must contain one line with the minimal possible total weight of colony with the accuracy of three decimal digits after the point.
Sample Input

3
72
30
50

Sample Output

120.000
题解:
题目就是说有n个物品,每个物品重w_i,对于两个物品他们合并时重量就会变成
w = 2 * sqrt(w_a * w_b)。 问当n个物品合成一个时,最小重量是多少?
在n个物品中取两个物品合并,要想最后总重最小,要每次取两个重量最大的物品。关于这个结论,下面给出证明:
设:n=3,三个物品的重量分比为:a,b,c, 合并之后最小重量为w。
则w = 2 * sqrt( a* 2 * sqrt(b * c) )
化简后的 w^2/8 = sqrt( aabc ), 此式可得 a 取最小时 w 的值最小。
所以就是每次先让最大的两个进行运算。
ac代码如下:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>
using namespace std;
int main()
{
	int n;
	double num,max,a,b;
	scanf("%d",&n);
		priority_queue<double>q;//我是直接用的优先队列这样就不用每次取完元素后排序了。
		while(n--)
		{
			scanf("%lf",&num);
			q.push(num);
		}
		max=q.top();
		while(q.size()>1)
		{
			a=q.top();
			q.pop();
			b=q.top();
			q.pop();
			max=2*sqrt(a*b);
			q.push(max);
		}
		printf("%.3f\n",max);
	return 0;
}

加油!!!

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值