HDU 3336 Count the string(KMP的next数组用法+DP)

Count the string

Problem Description

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: “abab”
The prefixes are: “a”, “ab”, “aba”, “abab”
   For each prefix, we can count the times it matches in s. So we can see that prefix “a” matches twice, “ab” matches twice too, “aba” matches once, and “abab” matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For “abab”, it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.

Input

The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.

Output

For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

Sample Input

1
4
abab

Sample Output

6
  题目大意是 给定字符串,求其前缀子串(从1开始的字符子串)在字符串中出现的次数。
  思路:1、题目满足KMP算法中匹配字符串的next数组求法(表示A中,以i结尾的非前缀子串与A的前缀子串最大匹配长度),只需求出next数组。
  2、对于next数组:例如对于长度为5的字符串,next[5]=3,说明有三个字符子串(s3~s5、 s4~s5 、s5)再次出现,同时不要忘记加上第一次出现的字符串本身(s1~s5)。

#include<iostream>
#define N 2000001
#define mod 10007
using namespace std;

string a;
int nex[N],n,m,j,dp[N];
int main()
{
    cin>>m;
    while(m--)
    {
        cin>>n;
        cin>>a;
        a='-'+a;
        nex[1]=j=0;
        for(int i=2;i<=n;i++)//求next数组
        {
            while(j&&a[i]!=a[j+1]) j=nex[j];
            if(a[i]==a[j+1]) j++;
            nex[i]=j;
        }
        int sum=0;
        for(int i=1; i<=n; i++)
        {
            dp[i]=(dp[nex[i]]+1)%mod;
            sum+=dp[i];
            sum%=mod;
        }
        cout<<sum<<endl;
    }
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值