4月6日学习总结

一、
知识点:

在学习C++的过程中我们经常会用到.和::和:和->,在此整理一下这些常用符号的区别。
1、A.B则A为对象或者结构体;
2、A->B则A为指针,->是成员提取,A->B是提取A中的成员B,A只能是指向类、结构、联合的指针;
3、::是作用域运算符,A::B表示作用域A中的名称B,A可以是名字空间、类、结构;
4、:一般用来表示继承;
最大的区别是->前面放的是指针,而.前面跟的是结构体变量。
详情请见:https://blog.csdn.net/zldz14/article/details/81227977
5、对vector中的元素用sort进行排序的正确方式为sort(a.begin(),a.end(),cmp) 假设a是vector类型的。
二、
Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0…N-1) so that she produces as much milk as possible.
Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.
Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

  • Line 1: Three space-separated integers: N, M, and R
  • Lines 2…M+1: Line i+1 describes FJ’s ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

  • Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input
12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output
43
解析:这个题挺简单,只要找到规律就好。代码和解析如下。

#include<iostream>
#include<cstdio>
#include<set>
#include<vector>
#include<algorithm>
using namespace std;
struct cows
{
    int sta,en,mai;
}w[1010];
bool cmp(cows a,cows b)//将奶牛的结束挤奶时间按从小到大排序,争取能够最大程度的挤奶次数最多,和贪心算法中安排最多活动的思路相同。
{
    return a.en<b.en;
}
int main()
{
  int n,m,r,dp[1010]={0};
  cin>>n>>m>>r;
  for(int i=1;i<=m;i++)
  {
      cin>>w[i].sta>>w[i].en>>w[i].mai;
  }
  sort(w+1,w+m+1,cmp);
  for(int i=1;i<=m;i++)
  {
      dp[i]=w[i].mai;//对dp进行初始化,当前时间的挤奶量
      for(int q=1;q<i;q++)//在前面的时间点中找最大的,以求得最大值。
      {
          if(w[i].sta-w[q].en>=r)
          dp[i]=max(dp[i],dp[q]+w[i].mai);
      }
  }
  int ans=0;
  for(int i=1;i<=m;i++)//找最大值输出
  {
      ans=max(ans,dp[i]);
  }
  cout<<ans<<endl;
  return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值