vj Wormholes POJ - 3259

题目:
While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1…N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself ? .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2… M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2… M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Lines 1… F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES
Hint
For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

思路:
这道题是让你判断存不存在负环,存在输出YES不存在输出NO。
判断是否存在负环,可以用spfa和floyd,跑一遍即可;
注意:用floyd不用scanf和printf输入和输出时间会超限。
下面使用spfa解决

代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
using namespace std;
const int maxn = 505;
const int INF = 0x3f3f3f3f;
int aa[maxn][maxn];
int dis[maxn], vis[maxn], ans[maxn];
int n, m, w;
int spfa(int s){ //模板
	queue <int> q;
	memset(vis, 0, sizeof(vis));
	memset(ans, 0, sizeof(ans));
	for(int i = 0; i <= n; i++){
		dis[i] = INF;
	}
	dis[s] = 0;
	vis[s] = 1;
	ans[s]++;
	q.push(s);
	while(!q.empty()){
		int u = q.front();
		q.pop();
		vis[u] = 0;
		for(int i = 0; i <= n; i++){
			if(aa[u][i] != INF){
				if(dis[i] > dis[u] + aa[u][i]){
					dis[i] = dis[u] + aa[u][i];
					if(!vis[i]){
						q.push(i);
						ans[i]++;
						if(ans[i] >= n) return -1;
						vis[i] = 1;
					} 
				}
			}
		}
	}
	return 1;
} 

int main(){
	int Q;
	scanf("%d", &Q);
	while(Q--){
		scanf("%d %d %d", &n, &m, &w);
		for(int i = 0; i <= n; i++){ //初始化aa数组
			for(int j = 0; j <= n; j++){
				if(i == j) aa[i][j] = 0;
				else aa[i][j] = INF;
			}
		}
		for(int i = 0; i < m; i++){
			int a, b, c;
			scanf("%d %d %d", &a, &b, &c);
			aa[a][b] = aa[b][a] = min(aa[a][b], c);
		}
		for(int i = 0; i < w; i++){
			int a, b, c;
			scanf("%d %d %d", &a, &b, &c);
			aa[a][b] = -c;
		}
		if(spfa(1) == 1) printf("NO\n");
		else printf("YES\n");
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值