stl新手练习

Most crossword puzzle fans are used to anagrams — groups of words with the same letters in different orders — for example OPTS, SPOT, STOP, POTS and POST. Some words however do not have this attribute, no matter how you rearrange their letters, you cannot form another word. Such words are called ananagrams, an example is QUIZ. Obviously such definitions depend on the domain within which we are working; you might think that ATHENE is an ananagram, whereas any chemist would quickly produce ETHANE. One possible domain would be the entire English language, but this could lead to some problems. One could restrict the domain to, say, Music, in which case SCALE becomes a relative ananagram (LACES is not in the same domain) but NOTE is not since it can produce TONE. Write a program that will read in the dictionary of a restricted domain and determine the relative ananagrams. Note that single letter words are, ipso facto, relative ananagrams since they cannot be “rearranged” at all. The dictionary will contain no more than 1000 words.

Input

Input will consist of a series of lines. No line will be more than 80 characters long, but may contain any number of words. Words consist of up to 20 upper and/or lower case letters, and will not be broken across lines. Spaces may appear freely around words, and at least one space separates multiple words on the same line. Note that words that contain the same letters but of differing case are considered to be anagrams of each other, thus ‘tIeD’ and ‘EdiT’ are anagrams. The file will be terminated by a line consisting of a single ‘#’.

Output

Output will consist of a series of lines. Each line will consist of a single word that is a relative ananagram in the input dictionary. Words must be output in lexicographic (case-sensitive) order. There will always be at least one relative ananagram.

Sample Input

ladder came tape soon leader acme RIDE lone Dreis peat ScAlE orb eye Rides dealer NotE derail LaCeS drIed noel dire Disk mace Rob dries #

Sample Output

Disk NotE derail drIed eye ladder soon

 

大意就是把那些字母一样的去掉,然后按字典序输出,其中需要将字符串中的字符转换为大写或小写,在我写的代码中我转换为了小写,在这道题我依然用到了set,利用set本身按从小到大的特点,符合了字典序,将存入set中的字符串输出,代码:

#include<cstdio>
#include<set>
#include<algorithm>
#include<iostream>
#include<cctype>
#include<string>
using namespace std;
set<string>s;
string str1[10000],str2[10000],str3[10000],str4[10000];  //str1是原本输入的保留,str2转小写用,str3是检索是否同一单词用,                                                                                              str4是用于防止多个比如三个出现 如:came mace eacm等
int main()
{
int a=1,l[3]={2,3,5};                 
set<string>::iterator iter;             //迭代器,用来连接set
while(cin>>str1[a])
{
    if(str1[a]=="#") break;        //输入#时停止
   str2[a]=str1[a];                     

    int c=str2[a].size();
    while(c)                       //将字符串转为小写
    {
        if(str2[a][c-1]>='A'&&str1[a][c-1]<='Z')  str2[a][c-1]=str2[a][c-1]+32;
        c--;
    }
    str3[a]=str2[a];
    str4[a]=str2[a];
    for(int b=1;b<a;++b)
{ int e=0;
    for(int d=0;d<str1[a].size();d++)
    {
        if(str1[b].size()>str1[a].size()||str1[a].size()>str1[b].size()) break;       //如果字母相同顺序不同那么长度一定相同,排除长度                                                                                                                          不同的情况

        if(str3[b][d]==str2[a][e]) {e++;str3[b][d]='*';d=-1;}         //如果找到相同字母,d一定等于-1,因为有个d++,这次循环后会                                                                                                        +1,下次循环从d为0开始

    }
    if(e==str1[a].size()) {str4[a]="*";str4[b]="*";}                //确保一样的让str4为*,一定双引号,因为是字符串
str3[b]=str2[b]; 
}
a++;

}
for(int b=1;b<=a-1;++b)
{
    if(str4[b]!="*") s.insert(str1[b]);              //如果str4不是*,就把str1放到set容器里
}
iter=s.begin();
for(int b=0;b<s.size();++b)
{
    cout<<*iter<<endl;                   //输出set中的元素
    iter++;
}
}
 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值