POJ-2188 Cow Laundry

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1372 Accepted: 883

Description

The cows have erected clothes lines with N (1 <= N <= 1000) wires upon which they can dry their clothes after washing them. Having no opposable thumbs, they have thoroughly botched the job. Consider this clothes line arrangement with four wires: 

   Wire slot: 1   2    3    4

              ---------------   <-- the holder of the wires

              \    \  /    /

               \    \/    /

                \   /\   /       

                 \ /  \ /       <-- actual clothes lines

                  /    \

                 / \  / \

                /   \/   \

               /    /\    \

              /    /  \    \

              ---------------   <-- the holder of the wires

   Wire slot: 1   2    3    4


The wires cross! This is, of course, unacceptable. 

The cows want to unscramble the clothes lines with a minimum of hassle. Even their bovine minds can handle the notion of "swap these two lines". Since the cows have short arms they are limited to swapping adjacent pairs of wire endpoints on either the top or bottom holder. 
In the diagram above, it requires four such swaps in order to get a proper arrangement for the clothes line: 

              1   2   3   4

              -------------   <-- the holder of the wires

              |   |   |   |

              |   |   |   |

              |   |   |   |

              |   |   |   |

              |   |   |   |

              |   |   |   |

              |   |   |   |

              |   |   |   |

              |   |   |   |

              -------------   <-- the holder of the wires

              1   2   3   4


Help the cows unscramble their clothes lines. Find the smallest number of swaps that will get the clothes line into a proper arrangement. 

You are supplied with clothes line descriptions that use integers to describe the current ordering of the clothesline. The lines are uniquely numbered 1..N according to no apparent scheme. You are given the order of the wires as they appear in the N connecting slots of the top wire holder and also the order of the wires as they appear on the bottom wire holder.

Input

* Line 1: A single integer: N 

* Lines 2..N+1: Each line contains two integers in the range 1..N. The first integer is the wire ID of the wire in the top wire holder; the second integer is the wire ID of the wire in the bottom holder. Line 2 describes the wires connected to top slot 1 and bottom slot 1, respectively; line 3 describes the wires connected to top and bottom slot 2, respectively; and so on. 
 

Output

* Line 1: A single integer specifying the minimum number of adjacent swaps required to straighten out the clothes lines. 

Sample Input

4
4 1
2 3
1 4
3 2

Sample Output

4

题意:每次交换相邻位置将第二列的顺序变为第列顺序。

解题思路:记录每个数据应该处于的位置,求一下逆序数就OK惹。

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<map>
using namespace std;
map<char,int>m;
int main()
{
    string s;
    for(int i=0; i<4; i++)
    {
        getline(cin,s);
        //getchar();
        for(int j=0; j<s.size(); j++)
            if(s[j]>='A'&&s[j]<='Z')
                m[s[j]]++;
    }
    int maxx=0;
    for(map<char,int>::iterator it=m.begin(); it!=m.end(); it++)
    {
        maxx=max(maxx,it->second);
    }
    //cout<<maxx<<endl;
    for(int i=0; i<maxx; i++)
    {
        for(int j=0; j<25; j++)
        {
            if(m['A'+j]+i>=maxx)cout<<"*"<<' ';
            else cout<<" "<<' ';
        }
        if(m['Z']+i>=maxx)
        cout<<"*"<<endl;
        else
        cout<<' '<<endl;
    }
    for(int i=0; i<26; i++){
        if(i==25)
        cout<<"Z"<<endl;
        else
        cout<<(char)('A'+i)<<' ';
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值