LightOJ1067 Combinations( Lucas定理或者技巧)

Given n different objects, you want to take k of them. How many ways to can do it?

For example, say there are 4 items; you want to take 2 of them. So, you can do it 6 ways.

Take 1, 2

Take 1, 3

Take 1, 4

Take 2, 3

Take 2, 4

Take 3, 4

Input

Input starts with an integer T (≤ 2000), denoting the number of test cases.

Each test case contains two integers n (1 ≤ n ≤ 106), k (0 ≤ k ≤ n).

Output

For each case, output the case number and the desired value. Since the result can be very large, you have to print the result modulo 1000003.

Sample Input

3

4 2

5 0

6 4

Sample Output

Case 1: 6

Case 2: 1

Case 3: 15

可以利用组合数的性质直接算,也可用卢卡斯定理,但都要先算出1e6的每个数的阶乘,不然超时。

#include <iostream>
#include <stdio.h>
using namespace std;
typedef long long ll;
#define mod 1000003
ll r[1000006];
ll mulit(ll a,ll b)
{
    ll ans=0;
    while(b)
    {
        if(b&1)
            ans=(ans+a)%mod;
        a=(a<<1)%mod;
        b>>=1;
    }
    return ans;
}
ll quick_mod(ll a,ll b)
{
    ll ans=1;
    while(b)
    {
        if(b&1)
        {
            ans=mulit(ans,a);
        }
        a=mulit(a,a);
        b>>=1;
    }
    return ans;
}
void get()
{
    r[0]=1;
    for(ll i=1; i<=1000002; i++)
        r[i]=r[i-1]*i%mod;
}
ll comp(ll a,ll b)
{
    if(a<b)
        return 0;
    if(a==b)
        return 1;
    if(b>a-b)
        b=a-b;
    return r[a]*quick_mod(r[b]*r[a-b]%mod,mod-2);//逆元不要先算出来1e6的,没必要,t<=2000,每个依次求更快;
}
ll lucas(ll a,ll b)
{
    ll ans=1;
    while(a&&b)
    {
        ans=(ans*comp(a%mod,b%mod))%mod;
        a/=mod;
        b/=mod;
    }
    return ans;
}
int main()
{
    ll a,b,t;
    get();
    scanf("%lld",&t);
    for(ll j=1; j<=t; j++)
    {
        scanf("%lld%lld",&a,&b);
        printf("Case %lld: %lld\n",j,lucas(a,b));
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值