PTA甲级 1007 Maximum Subsequence Sum (C++)

Given a sequence of K K K integers N 1 , N 2 , . . . , N K { N_1, N_2, ..., N_K} N1,N2,...,NK. A continuous subsequence is defined to be N i , N i + 1 , . . . , N j { N_i, N _{i+1}, ..., N_j} Ni,Ni+1,...,Nj where 1 ≤ i ≤ j ≤ K 1≤i≤j≤K 1ijK. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K ( ≤ 10000 ) K (≤10000) K(10000). The second line contains K K K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i i i and j j j (as shown by the sample case). If all the K K K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

Caution:

这个题有两个值得注意的点,很容易被坑到:

  • 要输出的后两个数是nums[i]nums[j]而不是ij,题目中的 Sample 刚好上面两个是一样的,所以很容易被迷惑,我一开始就是这一点弄错了导致只有最后一个测试点过了,其他都不正确;
  • 题意有一点描述的有问题,这一点还是受到这篇文章的启发,才知道题中描述的“如果数组全是负数则输出0 0 n-1”是不对的,应该是“如果算出来最大的和是负数的话输出 0 0 n-1”。

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-10 11:53:43
// All rights reserved.

#include <iostream>
#include <vector>

using namespace std;

int main(){
    int n;
    cin >> n;
    
    vector<int> nums(n);

    for(int i = 0; i < n; ++i) cin >> nums[i];

    int maxSum = nums[0], pos1 = 0, pos2 = 0;

    vector<vector<int>> dp(n, vector<int>(2, 0));

    dp[0][0] = nums[0];
    dp[0][1] = 0;

    for(int i = 1; i < n; ++i){

        if(dp[i - 1][0] + nums[i] >= nums[i]){
            dp[i][0] = dp[i - 1][0] + nums[i];
            dp[i][1] = dp[i - 1][1];
        }
        else{
            dp[i][0] = nums[i];
            dp[i][1] = i;
        }

        if(dp[i][0] > maxSum){
            maxSum = dp[i][0];
            pos1 = dp[i][1];
            pos2 = i;
        }
    }
    
    if(maxSum < 0){
        pos1 = 0;
        pos2 = n - 1;
        maxSum = 0;
    }
    
    cout << maxSum << ' ' << nums[pos1] << ' ' << nums[pos2] << endl;

    return 0;
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值