PTA甲级-1007 Maximum Subsequence Sum

题目内容

Given a sequence of K integers { N1, N2, …, N**K }. A continuous subsequence is defined to be { N**i, N**i+1, …, N**j } where 1≤ijK. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

一、题干大意

给出一串数字,要求输出其中连续的、总和最大的一串。如果有两串总和一样的,就输出位置靠前的那串;如果总和为负数的,就输出0和最前最后的两个数字。

二、题解要点

  • 动态规划的题目,其中最重要的思路就是当temp为负数的时候就把temp回归为0,并且从下一个位置开始重新计算总和。

三、具体实现

/**
*@Author:hhzheng
*@Date:2023/2/4  17:50
*@Filename:PAT甲级 1007 Maximum Subsequence Sum
*/

#include <iostream>
#include <vector>
using namespace std;
int main() {
    int n;
    scanf("%d", &n);
    vector<int> v(n);
    //leftIndex和rightIndex两个指明位置的参数直接设置为第一个和最后一个
    //以便作为总和小于0的那种情况的输出
    int leftIndex = 0, rightIndex = n - 1, sum = -1, temp = 0, tempIndex = 0;
    for (int i = 0; i < n; i++) {
        scanf("%d", &v[i]);
        //temp用来记录当前的总和
        temp = temp + v[i];
        //如果temp已经小于0了,那么这样的一串数就可以放弃了,因为从小于0开始加肯定不如直接放弃掉
        if (temp < 0) {
            temp = 0;
            tempIndex = i + 1;
        } else if (temp > sum) {
            //如果temp超过了历史记录的话 就把leftIndex转到tempIndex,rightIndex转到当前的下标
            sum = temp;
            leftIndex = tempIndex;
            rightIndex = i;
        }
    }
    if (sum < 0) sum = 0;
    printf("%d %d %d", sum, v[leftIndex], v[rightIndex]);
    return 0;
}

[外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-v9YqQLRV-1675514709581)(E:\刷题\PTA甲级\PTA1007流程图.png)]


# 总结

这个思路我是基本想到了,但是真正开始动手的时候发现一个模糊的思路是写不下去的,必须全局考虑到位才能动手,就是一定要胸有成竹才能一气呵成。柳神的代码还是一如既往的优美,我把链接贴下边:

https://www.liuchuo.net/archives/2122

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值