PTA甲级 1015 Reversible Primes (C++)

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N ( < 1 0 5 ) N (<10^5) N(<105) and D ( 1 < D ≤ 10 ) D (1<D≤10) D(1<D10), you are supposed to tell if N N N is a reversible prime with radix D D D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N N N and D D D. The input is finished by a negative N N N.

Output Specification:

For each test case, print in one line Yes if N N N is a reversible prime with radix D D D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-11 21:30:13
// All rights reserved.

#include <iostream>
#include <vector>
#include <cmath>

using namespace std;

bool isPrime(long long& num){
    if(num == 1) return false;
    if(num == 3 || num == 2) return true;
    long long factor = 2;

    while(factor <= num / factor){
        if(num % factor == 0) return false;
        factor++;
    }
    
    return true;
}

int main(){
    long long n, reversedN;
    int d;
    cin >> n;

    while(n >= 0){
        scanf("%d", &d);
        // 首先判断 n 是不是一个素数
        if(!isPrime(n)){
            cout << "No" << endl;
            cin >> n;
            continue;
        }

        // 到这里说明 n 是一个素数,接下来找到 n 的 d 进制下的 reverse,判断他是不是素数
        // 先找到 n 在 d 进制下的表示

        string dRadixOfN = "";
        reversedN = 0;

        while(n != 0){
            int yushu = n % d;
            int shang = n / d;

            dRadixOfN = (char)(yushu + '0') + dRadixOfN;

            n = shang;
        }

        for(int i = dRadixOfN.length() - 1; i >= 0; --i) reversedN += (long long)(dRadixOfN[i] - '0') * pow(d, i);
        // cout << reversedN << endl;
        
        if(isPrime(reversedN)) cout << "Yes" << endl;
        else cout << "No" << endl;

        cin >> n;
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值