pta甲级1015 Reversible Primes(AC)

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<105) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

结尾无空行

Sample Output:

Yes
Yes
No

结尾无空行

思路:

重点就在一个判断素数和进制转化,难度不大。

#include<bits/stdc++.h>
using namespace std;

bool isprime(int a)
{
	if(a==1) return 0;
	if(a==2) return 1;
	for(int i=2;i<=sqrt(a)+1;i++){
		if(a%i==0) return 0;
	}
	return 1;
}

int main()
{
	while(1){
		int num[10005]={0};
		int x=0,n2=0,n,d,temp;
		cin>>n;
		if(n<0) break;
		cin>>d;
	    if(!isprime(n)) printf("No\n"); //n如果不是素数,直接输出No 
	    else if(isprime(n)){
			while(n){ //进制转化,顺便将其颠倒
           		num[x++]=n%d;
            	n/=d;
        	}
			for(int i=0;i<x;i++) n2=num[i]+n2*d; 
			if(!isprime(n2)) printf("No\n");
			else printf("Yes\n");
        }
	}
}

 

 

  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值