PTA甲级 1045 Favorite Color Stripe (C++)

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva’s favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva’s favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N ( ≤ 200 ) N (≤200) N(200) which is the total number of colors involved (and hence the colors are numbered from 1 to N N N). Then the next line starts with a positive integer M ( ≤ 200 ) M (≤200) M(200) followed by M M M Eva’s favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L ( ≤ 1 0 4 ) L (≤10^4) L(104) which is the length of the given stripe, followed by L L L colors on the stripe. All the numbers in a line a separated by a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva’s favorite stripe.

Sample Input:

6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6

Sample Output:

7

Caution:

可以转化成 Leetcode 上这道最长递增子序列的问题。

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-24 13:32:54
// All rights reserved.

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;

int main(){
    int n, m, l;
    // n - the total number of colors involved
    // followed by M Eva's favorite color numbers given in her favorite order

    scanf("%d", &n);
    scanf("%d", &m);
    vector<int> eva(m);
    vector<vector<int>> position(m);
    for(int i = 0; i < m; ++i) scanf("%d", &eva[i]);

    scanf("%d", &l);
    int size = 0;

    for(int i = 0; i < l; ++i){
        int tmp;
        scanf("%d", &tmp);

        int pos = find(eva.begin(), eva.end(), tmp) - eva.begin();

        if(pos != m){
            position[pos].push_back(i);
            size++;
        }
    }

    int* tmp = new int[size];
    int pos = 0;
    for(int i = 0; i < m; ++i)
        for(int j = 0; j < position[i].size(); ++j) tmp[pos++] = position[i][j];

    int* dp = new int[size];
    for(int i = 0; i < size; ++i){
        dp[i] = 1;

        for(int j = 0; j < i; ++j){
            if(tmp[j] < tmp[i]) dp[i] = max(dp[i], dp[j] + 1);
        }
    }
    
    printf("%d\n", *max_element(dp, dp + size));

    return 0;
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值