PTA甲级 1036 Boys vs Girls (C++)

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N N N, followed by N N N lines of student information. Each line contains a student’s name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference g r a d e F − g r a d e M grade_F−grade_M gradeFgradeM. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-16 13:05:18
// All rights reserved.

#include <iostream>
#include <vector>

using namespace std;

struct Student{
    string name;
    string ID;
    char gender;
    int grade;

    Student(string n, string id, char ge, int g){
        name = n;
        ID = id;
        gender = ge;
        grade = g;
    }

    ~Student(){}
};

int main(){
    int n;
    scanf("%d", &n);
    string name, ID;
    char gender;
    int grade;

    int maleMinPos = -1, femaleMaxPos = -1;
    vector<Student> students;

    for(int i = 0; i < n; ++i){
        cin >> name >> gender >> ID >> grade;

        students.emplace_back(name, ID, gender, grade);

        if(gender == 'M'){
            if(maleMinPos == -1) maleMinPos = i;
            else if(grade < students[maleMinPos].grade) maleMinPos = i;
        } 
        else{
            if(femaleMaxPos == -1) femaleMaxPos = i;
            else if(grade > students[femaleMaxPos].grade) femaleMaxPos = i;
        }
    }

    if(femaleMaxPos == -1){
        printf("Absent\n");
        printf("%s %s\n", students[maleMinPos].name.c_str(), students[maleMinPos].ID.c_str());
        printf("NA\n");
        
        return 0;
    }

    else if(maleMinPos == -1){
        printf("%s %s\n", students[femaleMaxPos].name.c_str(), students[femaleMaxPos].ID.c_str());
        printf("Absent\n");
        printf("NA\n");
        
        return 0;
    }

    printf("%s %s\n", students[femaleMaxPos].name.c_str(), students[femaleMaxPos].ID.c_str());
    printf("%s %s\n", students[maleMinPos].name.c_str(), students[maleMinPos].ID.c_str());
    printf("%d\n", students[femaleMaxPos].grade - students[maleMinPos].grade);

    return 0;
}

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值