【PAT甲级 - C++题解】1036 Boys vs Girls

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1036 Boys vs Girls (pintia.cn)
🔑中文翻译:男孩 vs 女孩
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1036 Boys vs Girls

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student’s name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF−gradeM. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA

思路

  1. 这道题可以边输入边判断,用几个变量来存储对应的最大值和最小值。
  2. 最后输出的时候要注意男生和女生的个数。

代码

#include<bits/stdc++.h>
using namespace std;

int main()
{
    int n;
    cin >> n;
    string girl_name, girl_id;
    int girl_score;
    string boy_name, boy_id;
    int boy_score;

    for (int i = 0; i < n; i++)
    {
        string name, gender, id;
        int score;
        cin >> name >> gender >> id >> score;
        if (gender == "F") //如果是女生
        {
            if (girl_name.empty() || score > girl_score)
            {
                girl_name = name;
                girl_id = id;
                girl_score = score;
            }
        }
        else    //如果是男生
        {
            if (boy_name.empty() || score < boy_score)
            {
                boy_name = name;
                boy_id = id;
                boy_score = score;
            }
        }
    }

    //判断是否有女生
    if (girl_name.empty())   puts("Absent");
    else    cout << girl_name << " " << girl_id << endl;
    //判断是否有男生
    if (boy_name.empty())    puts("Absent");
    else    cout << boy_name << " " << boy_id << endl;
    //判断男生女生是否都存在,如果存在就输出成绩差值
    if (boy_name.size() && girl_name.size()) cout << girl_score - boy_score << endl;
    else    cout << "NA" << endl;

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值