PTA甲级 1068 Find More Coins (C++)

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 1 0 4 10^4 104 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N ( ≤ 1 0 4 ≤10^4 104, the total number of coins) and M ( ≤ 1 0 2 ≤10^2 102, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the face values V 1 ≤ V 2 ≤ ⋯ ≤ V k V_1≤V_2≤⋯≤V_k V1V2Vk such that V 1 + V 2 + ⋯ + V k = V_1+V_2+⋯+V_k= V1+V2++Vk=M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output “No Solution” instead.

Note: sequence {A[1], A[2], …} is said to be “smaller” than sequence {B[1], B[2], …} if there exists k ≥ 1 k≥1 k1 such that A[ i i i]=B[ i i i] for all i < k i<k i<k, and A[ k k k] < B[ k k k].

Sample Input 1:

8 9
5 9 8 7 2 3 4 1

Sample Output 1:

1 3 5

Sample Input 2:

4 8
7 2 4 3

Sample Output 2:

No Solution

Caution:

DFS,但是要注意剪枝,尤其是遇到重复的数据,最后一个测试点里面应该是有很多这样的数据。

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-21 10:26:32
// All rights reserved.

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;

int n;
bool flags[10010] = {false};
int coins[10010];
bool hasAns = false;

void dfs(int sum, int idx, vector<int>& tmp){

    for(int i = idx + 1; i < n && !hasAns && coins[i] <= sum; ++i){
        
        if(i >= 1 && coins[i] == coins[i - 1] && flags[i - 1] == false) continue;

        if(coins[i] == sum){
            for(int i = 0; i < tmp.size(); ++i) printf("%d ", tmp[i]);
            printf("%d\n", coins[i]);

            hasAns = true;
            return;
        }

        else{
            tmp.push_back(coins[i]);
            flags[i] = true;

            dfs(sum - coins[i], i, tmp);

            tmp.pop_back();
            flags[i] = false;
        }
    }

    return;
}


int main(){
    int m;

    scanf("%d %d", &n, &m);

    for(int i = 0; i < n; ++i) scanf("%d", &coins[i]);
    sort(coins, coins + n);

    vector<int> tmp;

    dfs(m, -1, tmp);
    if(!hasAns) printf("No Solution\n");

    return 0;
}

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值