1048 Find Coins (25分) 散列 C++

1048 Find Coins (25分)
Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 10
​5
​​ coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10
​5
​​ , the total number of coins) and M (≤10
​3
​​ , the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the two face values V
​1
​and V
​2
​​ (separated by a space) such that V
​1
​​ +V
​2
​​ =M and V
​1
​​ ≤V
​2
​​ . If such a solution is not unique, output the one with the smallest V
​1
​​ . If there is no solution, output No Solution instead.

Sample Input 1:
8 15
1 2 8 7 2 4 11 15
Sample Output 1:
4 11
Sample Input 2:
7 14
1 8 7 2 4 11 15
Sample Output 2:
No Solution

**题目分析:**eva有一些硬币,用现有的两枚硬币凑出题目中给出的金额;用hashTable[1001]的数组存各种硬币的个数;
注意:1. 将输入的数组排序,保证输出的v1是最小的;2. 当用两个相同硬币时,需要判断硬币数是否大于等于2;

#include <cstdio>
#include <algorithm>
using namespace std;

int a[100005], hashTable[1005];

int main() {
    int n, m, v1, v2, num, flag = 0;
    scanf("%d %d", &n, &m);

    for (int i=0; i<n; i++) {
        scanf("%d", &a[i]);
        hashTable[a[i]]++;  // 记录每种面额的个数
    }
    sort(a, a+n);
    for (int i=0; i<n; i++) {
        v1 = a[i];
        v2 = m - v1;
        num = v1 == v2 ? 1 : 0;  // 如果v1 == v2,则该面额的硬币至少有两个
        if (hashTable[v2] > num) {
            printf("%d %d\n", v1, v2);
            flag = 1;
            break;
        }
    }

    if (flag == 0) printf("No Solution\n");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值