PTA甲级 1115 Counting Nodes in a BST (C++)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than or equal to the node’s key.
  • The right subtree of a node contains only nodes with keys greater than the node’s key.
  • Both the left and right subtrees must also be binary search trees.

Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N ( ≤ 1000 ) N (≤1000) N(1000) which is the size of the input sequence. Then given in the next line are the N N N integers in [ − 1000 , 1000 ] [−1000,1000] [1000,1000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:

9
25 30 42 16 20 20 35 -5 28

Sample Output:

2 + 4 = 6

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-26 11:34:37
// All rights reserved.

#include <iostream>
#include <vector>
#include <unordered_map>

using namespace std;

int deepestLevel = 1;
unordered_map<int, int> levels;

struct Node{
    int key;
    Node *left;
    Node *right;
    int level;

    Node(int k, int l){
        key = k;
        level = l;

        left = NULL;
        right = NULL;
    }
    ~Node(){}
};

void insert(int key, Node *root){
    if(key <= root -> key){
        if(root -> left == NULL){
            root -> left = new Node(key, root -> level + 1);
            levels[root -> level + 1]++;
            deepestLevel = max(deepestLevel, root -> level + 1);
        }
        else insert(key, root -> left);
    }
    else{
        if(root -> right == NULL){
            root -> right = new Node(key, root -> level + 1);
            levels[root -> level + 1]++;
            deepestLevel = max(deepestLevel, root -> level + 1);
        }
        else insert(key, root -> right);
    }
}

int main(){
    int n, n1, n2;
    cin >> n;

    int tmp;
    cin >> tmp;

    Node *root = new Node(tmp, 1);
    
    levels[1]++;
    
    for(int i = 0; i < n - 1; ++i){
        cin >> tmp;
        insert(tmp, root);
    }

    printf("%d + %d = %d\n", levels[deepestLevel], levels[deepestLevel - 1], levels[deepestLevel] + levels[deepestLevel - 1]);

    return 0;
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值