PTA甲级 1128 N Queens Puzzle (C++)

The “eight queens puzzle” is the problem of placing eight chess queens on an 8 × 8 8×8 8×8 chessboard so that no two queens threaten each other. Thus, a solution requires that no two queens share the same row, column, or diagonal. The eight queens puzzle is an example of the more general N N N queens problem of placing N N N non-attacking queens on an N × N N×N N×N chessboard. (From Wikipedia - “Eight queens puzzle”.)
在这里插入图片描述

Input Specification:

Each input file contains several test cases. The first line gives an integer K ( 1 < K ≤ 200 ) K (1<K≤200) K(1<K200). Then K K K lines follow, each gives a configuration in the format " N N N Q 1 Q_1 Q1 Q 2 Q_2 Q2 Q N Q_N QN", where 4 ≤ N ≤ 1000 4≤N≤1000 4N1000 and it is guaranteed that 1 ≤ Q i ≤ N 1≤Q_i ≤N 1QiN for all i = 1 , ⋯ , N i=1,⋯,N i=1,,N. The numbers are separated by spaces.

Output Specification:

For each configuration, if it is a solution to the N N N queens problem, print YES in a line; or NO if not.

Sample Input:

4
8 4 6 8 2 7 1 3 5
9 4 6 7 2 8 1 9 5 3
6 1 5 2 6 4 3
5 1 3 5 2 4

Sample Output:

YES
NO
NO
YES

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-28 17:19:19
// All rights reserved.

#include <iostream>
#include <vector>
#include <unordered_map>

using namespace std;

int cases[1010];

bool isSolution(int n){
    unordered_map<int, bool> rows, diag, rdiag;

    for(int i = 1; i <= n; ++i){
        if(rows[cases[i]] == true || diag[i + cases[i]] == true || rdiag[i + n + 1 - cases[i]] == true) return false;

        rows[cases[i]] = true;
        diag[i + cases[i]] = true;
        rdiag[i + n + 1 - cases[i]] = true;
    }

    return true;
}

int main(){
    int k;
    scanf("%d", &k);

    for(int i = 0; i < k; ++i){
        int num;
        scanf("%d", &num);

        for(int j = 1; j <= num; ++j) scanf("%d", &cases[j]);
        if(isSolution(num)) printf("YES\n");
        else printf("NO\n");
    }

    return 0;
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值